Bug 734879 - Drift display issue ... Change Sets-->Context Menu--->Details
Drift display issue ... Change Sets-->Context Menu--->Details
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 707225
  Show dependency treegraph
 
Reported: 2011-08-31 14:06 EDT by Mike Foley
Modified: 2012-02-07 14:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:18:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
drift display issue (60.05 KB, image/png)
2011-08-31 14:06 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-08-31 14:06:20 EDT
Created attachment 520871 [details]
drift display issue

Description of problem:  Drift display issue ... Change Sets-->Context Menu--->Details 


Version-Release number of selected component (if applicable):


How reproducible:
100^

Steps to Reproduce:
1.  Drift change set, right click context menu, choose details
2.  Observe display issue (see attached)

  
Actual results:
see attached image of display issue


Expected results:
proper display

Additional info:
attachment
Comment 1 Mike Foley 2011-08-31 16:22:22 EDT
Steps to repro:
-change sets
-expand Version 0 node
-right-click context menu on the 1st item 
-select details from the context menu
-then i see the display issue with the details page, that is documented and attached to this BZ
Comment 2 Mike Foley 2011-08-31 16:43:12 EDT
Conversation from Elluminate session where we reproduced the issue, and documented the additional reproduction steps:

oined on August 31, 2011 at 4:27 PM
jshaughn: ok
jshaughn: I can see your stuff
jshaughn: refresh is slow
Moderator: ok ...here goes ...
jshaughn: wait
Moderator: i clicked on change sets
jshaughn: first, click on Reports
Moderator: let me do my steps ...ok?
jshaughn: not ok
jshaughn: because you're already farther than I want you to be
Moderator: ok
jhaughn: I belive there is a problem, don't get me wrong
Moderator: we saw the issue ... there it is
jshaughn: I want to ensure that we're seeing the same problem
Moderator: i  will now click on reports
Moderator: this is not in my reproduction steps ...so the outcome here is unknown to me
jshaughn: i am not questioning whether there is a problem, I want to ensure there are not two problems
Moderator: i have clicked on reports
Moderator: what is the next thing i need to do
jshaughn: ok, no you can go to favorites, recently viewed or whatever to get back to your platfoirm
jshaughn: not the back button
Moderator: i will stick to the reproduction steps that i have documented
jshaughn: right
jshaughn: thatis what I'm talking about
Moderator: and the problem does not reproduce after clicking reports
jshaughn: you're repro steps need to be cleaner for this one
jshaughn: that is what I'm saying
jshaughn: because they start once you've already been playing with the drift subtabs
jshaughn: and I had no idea whatyou had already done
jshaughn: anyway, it's ok, I just needed to confirm we were on the same page
jshaughn: you can see it if you now click back to list
Moderator: is state of the UI "dirty" in some way?
Moderator: if the state of the UI is dirty ... then that is another issue
jshaughn: wrt to this bug, yes, the repr steps started in a non-determinsitic state
jshaughn: Now, hit back to list
jshaughn: it's not an issue with anything other than the repro steps
jshaughn: ok, now go ahead and follow your repro steps
Moderator: i have already done that twice
Moderator: once the issue was repro'd
Moderator: and the 2nd time it was not repro'd
jshaughn: try now
Moderator: what are we testing in this 3rd try?
jshaughn: you will see it
jshaughn: because we are now in your original state
Moderator: okay ...
Moderator: so clicking "History": leaves the UI in a dirty state
jshaughn: call it what you want, it's part of the repro steps
jshaughn: ok, thanks, we are now on the same page
Comment 3 Jay Shaughnessy 2011-08-31 18:00:11 EDT
This is similar in look to Bug 730065 but its cause is different, and
tricky.  Looking into it.
Comment 4 Jay Shaughnessy 2011-09-01 10:31:13 EDT
master commit 153c9845c2ac28079b9629b4cc445d7eccca8901

Even if the table view is not visible, it may not be hidden. Instead, it
may be the case that its parent (the encompassing Table/HLayout) may not
be visible.  This is unusual because typically we switch between the table
and detail view while under the subtab, but if we navigate to the detail
view from another subtab (for example, the drift tree context
menu) the Table may not be visible and the table view may not be hidden.
To make a long story short, ensure the table view is hidden when
displaying the details view.
Comment 5 Mike Foley 2011-09-02 10:45:45 EDT
verified RHQ 4.1 release candidate.
Comment 6 Mike Foley 2012-02-07 14:18:36 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.