Bug 734880 - subscription-manager list --installed reports differently between LEGACY vs NEW SKU subscriptions
subscription-manager list --installed reports differently between LEGACY vs ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
: 734990 (view as bug list)
Depends On:
Blocks: rhsm-rhel62 743047
  Show dependency treegraph
 
Reported: 2011-08-31 14:11 EDT by John Sefler
Modified: 2011-12-06 12:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:23:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-08-31 14:11:27 EDT
Description of problem:
I'm not sure about the severity of this bug, but our automated tests against stage are catching this and I don't what to do about it.  Subscription-manager list --installed does not appear to filter out all the content sets from an entitlement grated on a LEGACY SKU.  Take a look at the recreate steps on a rhel-6-server system registered against subscription.rhn.stage.redhat.com for an example...


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.7-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-stage-6server ~]# ls /etc/pki/product/
69.pem

[root@jsefler-stage-6server ~]# grep hostname /etc/rhsm/rhsm.conf
# Server hostname:
hostname=subscription.rhn.stage.redhat.com
proxy_hostname=



[root@jsefler-stage-6server ~]# subscription-manager register --user stage_test_12
Password: 
The system has been registered with id: 6916c2a5-1761-49e6-a8ac-a2b0e2a81971 
[root@jsefler-stage-6server ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	91                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	400                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual   



NOW LET"S SUBSCRIBE TO THE NEW SKU RH0103708


[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/08/2012               
SerialNumber:       	7807222014485290844      
ContractNumber:     	2394344                  
AccountNumber:      	1465502     


^^^ THAT LOOKS CORRECT SINCE PRODUCT 69.pem IS INSTALLED AND NOW COMPLIANT

NOW LET'S TRY THE LEGACY SKU MCT1035...

[root@jsefler-stage-6server ~]# subscription-manager unsubscribe --all
[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201309911639a0c51
Successfully subscribed the system to Pool 8a99f981308acf4201309911639a0c51
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Server
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Server
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Server
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:             	Subscribed               
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:             	Subscribed               
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:             	Subscribed               
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/15/2012               
SerialNumber:       	2855135061909597638      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  

[root@jsefler-stage-6server ~]# 


^^^ WHOOOAH- THAT'S A BIG LIST FOR ONE INSTALLED 69.pem PRODUCT CERT. IT IS VERY DIFFERENT FROM THE REPORT AFTER SUBSCRIBING TO THE NEW SKU RH0103708 THAT IS SUPPOSED TO PROVIDE THE SAME CONTENT AS THE LEGACY SKU. THE LIST CONTAINS CONFLICTING RESULTS.  ALTHOUGH THEY ALL COME FROM THE SAME SerialNumber AS EXPECTED, THE STATUS REPORT IS DIFFERENT FOR REPEATED ProductNames.
THIS REPORT IS VERY CONFUSING, CONTRADICTING, AND I DON'T KNOW WHAT TO DO ABOUT IT.  MAYBE WE NEED MORE FIELDS IN THE REPORT TO DISTINGUISH THE DATA, OR BETTER FILTERING TO REDUCE THE LIST FOR LEGACY PRODUCTS.
Comment 1 Bryan Kearney 2011-09-02 13:42:26 EDT
*** Bug 734990 has been marked as a duplicate of this bug. ***
Comment 2 Bryan Kearney 2011-09-07 12:37:05 EDT
Fixed in master branch of subscription-manager in commit 37f3e445bab6551bc4a6e5f8eebf2758f77c196a.
Comment 4 John Sefler 2011-09-12 15:48:34 EDT
Verifying Version...
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.9-1.el6.x86_64

To verify, I'm simply going to reproduce the same test path in comment 0

[root@jsefler-stage-6server ~]# ls /etc/pki/product/
69.pem
[root@jsefler-stage-6server ~]# grep hostname /etc/rhsm/rhsm.conf
# Server hostname:
hostname = subscription.rhn.stage.redhat.com
proxy_hostname =
[root@jsefler-stage-6server ~]# subscription-manager register --user stage_test_12
Password: 
The system has been registered with id: eab1dfea-d0d4-4f29-991b-12d7e8a3f406 
[root@jsefler-stage-6server ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	92                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	397                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual                  

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/08/2012               
SerialNumber:       	3120059695408345698      
ContractNumber:     	2394344                  
AccountNumber:      	1465502                  

[root@jsefler-stage-6server ~]# subscription-manager unsubscribe --all
[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201309911639a0c51
Successfully subscribed the system to Pool 8a99f981308acf4201309911639a0c51
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	1344120492409076466      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	1344120492409076466      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:             	Not Installed            
Expires:            	06/15/2012               
SerialNumber:       	1344120492409076466      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  


ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/15/2012               
SerialNumber:       	1344120492409076466      
ContractNumber:     	2394396                  
AccountNumber:      	1465502                  

[root@jsefler-stage-6server ~]# 


^^^ VERIFIED, the list --installed no longer reports any duplicate/conflicting installed products.  Looks good.

moving to VERIFIED

Note: The behavior demonstrated in these verification steps may change depending on the outcome of design changes from bug 736424.
Comment 5 errata-xmlrpc 2011-12-06 12:23:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.