Bug 734906 - Firstboot on F15 problem on ntp section.
Summary: Firstboot on F15 problem on ntp section.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 736181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 20:04 UTC by Oscar Osta
Modified: 2012-08-07 17:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 17:26:16 UTC


Attachments (Terms of Use)

Description Oscar Osta 2011-08-31 20:04:17 UTC
Description of problem:
Firstboot on F15 problem on ntp section and can't follow the process.

Version-Release number of selected component (if applicable):
fedora 15 i386 from DVD.
firstboot-1.119-1.fc15.i686

How reproducible:
Yes

Steps to Reproduce:
1. Install F15 (32 bits) from DVD.
2. Select "F15 - i386" and "F15 - i386 - updates" repositories.
3. Install.
4. Reboot.
5. Firsboot on the section "ntp" can't select "ntp sync". Can't follow the process.
  
Actual results:


Expected results:


Additional info:
1. I installed from console ntp-4.2.6p3-4.fc15.i686 and ntp-4.2.6p3-4.fc15.i686 from console.
2. Reboot the machine.
3. Firstboot work fine.

Thanks for all,

Comment 1 birger 2011-09-03 08:36:43 UTC
I am also seeing this.

Freshly installed Fedora 15 using B.F.O. installer for F15 i386. Default 'Graphical Desktop' install. The only change was using btrfs instead of ext for /

After the install and first reboot (at the first firstboot screen) I switched to ascii console (ctrl-alt-f2) and added some packages before rebooting. At the date and time screen firstboot does not offer ntp (greyed out), and the next button does nothing. After reading this bz, I again switched to ascii, installed ntp and ntpdate and rebooted. Now firstboot works fine.

Should ntp be in the default desktop install?

Anyway, firstboot should have worked without ntp...

Comment 2 Samuel Sieb 2011-09-06 23:04:58 UTC
I just did a clean install on a laptop with updates enabled and see the same issue.  Can't select time sync and can't go to next.  Was there some change in the updates that messed this up recently?

Comment 3 Marcin Zajaczkowski 2011-09-06 23:13:22 UTC
*** Bug 736181 has been marked as a duplicate of this bug. ***

Comment 4 Martin Gracik 2011-09-09 10:43:18 UTC
I tried this with Fedora 16. After normal Graphical Desktop installation, I got firstboot ntp settings working properly. The ntp package was not installed, but the chrony package was installed instead.

I tried removing the chrony package then, so there was no ntp or chrony installed, and run firstboot again. Now the ntp sync option was greyed out, but after pressing forward I got the hardware profile screen and firstboot worked normally.

So what I think happened. In F15 the default was ntp, in F16 it changed to chrony. But if you use F15 with updates, somehow you will end up with none, so the ntp sync is greyed out because of that. But I couldn't reproduce not being able to go to next screen in firstboot. It worked for me.

Can you test this with F16 Alpha?

Either way, if this is still a valid bug, it needs to be reassigned, either to comps, so ntp or chrony is installed, or to system-config-date, where the time and date module comes from.

Comment 5 Marcin Zajaczkowski 2011-09-09 11:12:04 UTC
I was installing Fedora 16 Alpha a few days ago and besides problem with Smolt (empty hardware profile tab - problem marked as a known bug) there was no problem like mentioned in Fedora 15.

Have there be the updates of mentioned packages since 2011-09-06?

Comment 6 Rolle 2011-10-25 14:05:30 UTC
These Bugreports may address the same problem:
Bug 734906
Bug 736181
Bug 737235
Bug 747869

Comment 7 Fedora End Of Life 2012-08-07 17:26:18 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.