Bug 735036 - Anaconda does a crash and burn on fresh installs
Summary: Anaconda does a crash and burn on fresh installs
Keywords:
Status: CLOSED DUPLICATE of bug 728122
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 09:01 UTC by Jes Sorensen
Modified: 2011-09-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 23:40:46 UTC


Attachments (Terms of Use)
anaconda explosion log (475.16 KB, text/plain)
2011-09-02 13:01 UTC, Jes Sorensen
no flags Details
more anaconda log (10.45 KB, text/plain)
2011-09-02 13:01 UTC, Jes Sorensen
no flags Details

Description Jes Sorensen 2011-09-01 09:01:52 UTC
Description of problem:
Laptop drive died, decided to give F16 Alpha a spin. Put the image on a
USB stick.

Get as far as Anaconda trying to read the drives, before it crashes and
burns with some python gibberish message.

Tried both with a brand new uninstalled harddrive and after installing
F15 on the system first.

Version-Release number of selected component (if applicable):
Whatever is on the F16 Alpha iso image

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Lehman 2011-09-01 14:11:21 UTC
"some python gibberish message"?

Please attach the file that matches /tmp/anaconda-tb-* to this bug report as type text/plain so we can actually tell what happened.

Comment 2 Jes Sorensen 2011-09-01 14:48:59 UTC
How do you expect me to get hold of that file? The installation crashes
long before it starts writing anything to the system disk - all I can do
is reboot and try in a different way.

It's easy to reproduce, just take the Fedora 16 Alpha DVD image, put it onto
a USB stick using livecd-iso-to-disk and try and install it, it doesn't
get very far.

As for gibberish, then I refer to python error messages, they are pure
gibberish.

Jes

Comment 3 David Lehman 2011-09-01 15:06:25 UTC
(In reply to comment #2)
> How do you expect me to get hold of that file? The installation crashes
> long before it starts writing anything to the system disk - all I can do
> is reboot and try in a different way.

You can get a shell by pressing ctrl+alt+f2 and then use the scp command to transfer the file to another computer.

> 
> It's easy to reproduce, just take the Fedora 16 Alpha DVD image, put it onto
> a USB stick using livecd-iso-to-disk and try and install it, it doesn't
> get very far.

It gets all the way through for many hundreds of users so far. What you don't realize is that there is something about your system's configuration that is specifically causing this crash. That is why I need your logs.

> 
> As for gibberish, then I refer to python error messages, they are pure
> gibberish.

To you, perhaps they are gibberish. To someone who knows python they are a valuable source of information. You should always include the full error message when reporting any bug. Dismissing this information as gibberish is disrespectful to the engineers you are asking to fix your issue, and also just prevents progress on your issue.

Comment 4 Jes Sorensen 2011-09-02 13:01:03 UTC
Created attachment 521223 [details]
anaconda explosion log

Comment 5 Jes Sorensen 2011-09-02 13:01:35 UTC
Created attachment 521224 [details]
more anaconda log

Comment 6 Jes Sorensen 2011-09-02 13:05:53 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > How do you expect me to get hold of that file? The installation crashes
> > long before it starts writing anything to the system disk - all I can do
> > is reboot and try in a different way.
> 
> You can get a shell by pressing ctrl+alt+f2 and then use the scp command to
> transfer the file to another computer.

Well there you go. This crash is from a corporate issue standard laptop,
ie. Lenovo X200. Nothing special about it.

> > As for gibberish, then I refer to python error messages, they are pure
> > gibberish.
> 
> To you, perhaps they are gibberish. To someone who knows python they are a
> valuable source of information. You should always include the full error
> message when reporting any bug. Dismissing this information as gibberish is
> disrespectful to the engineers you are asking to fix your issue, and also just
> prevents progress on your issue.

Yes indeed they are. I cannot help longing for the old installer where I was
able to at least look at the backtrace and the output and actually make sense
of it.

I realize some people feel strongly in favour of python, but to the rest of
us, it's the C++ of scripting languages :(

Comment 7 David Lehman 2011-09-02 15:25:18 UTC
(In reply to comment #6)
> Yes indeed they are. I cannot help longing for the old installer where I was
> able to at least look at the backtrace and the output and actually make sense
> of it.

What old installer? Anaconda has been around for over ten years.


The first lines of the crash log are the traceback:

anaconda 16.14.6 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 98, in _reschedule
    self.namesched(to_sched)))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 148, in schedule
    return self._reschedule(self.SCHED_SCHEDULED, current_step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in <lambda>
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in schedule_steps
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 288, in setSteps
    "complete"
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/examine_gui.py", line 43, in getNext
    upgrade.setSteps(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1194, in nextClicked
    rc = self.currentWindow.getNext ()
DispatchError: Can not reschedule step 'language' from 'skipped' to 'scheduled'

Local variables in innermost frame:
current_step: <pyanaconda.dispatch.Step object at 0x7fd5b7dba9d0>
self: <pyanaconda.dispatch.Step object at 0x7fd5b7dba810>
to_sched: 1
s_from: 2
new_sched: False


It looks like the language was specified incorrectly and the installer crashed when trying to reschedule the step to show the language selection screen once it discovered the initially provided lang string was unusable.

There is a bug here, but you can probably work around it by specifying lang=en_US.UTF-8 instead of lang=en_US.utf8. I know, it's a subtle difference.

Comment 8 Jes Sorensen 2011-09-02 15:39:31 UTC
I am not sure what you mean by specifying language here? All I do is pick
US keyboard when I am prompted for that. Then it launches the GUI and goes
from there.

I am never offered a choice of language in the process.

Comment 9 David Lehman 2011-09-02 15:57:44 UTC
12:29:25,267 INFO loader: kernel command line:
12:29:25,268 INFO loader:     initrd=initrd.img
12:29:25,268 INFO loader:     LANG=en_US.utf8
12:29:25,268 INFO loader:     repo=hd:UUID=8061aeee-6150-4b95-a473-a7917656bf7d:/
12:29:25,268 INFO loader:     quiet
12:29:25,269 INFO loader:     BOOT_IMAGE=vmlinuz

Who has set the kernel command line if not you?

Comment 10 Jes Sorensen 2011-09-02 20:14:52 UTC
As mentioned earlier, all I did was download the Fedora 16 Alpha iso image,
put it on a USB stick using livecd-iso-to-disk, stick the USB stick in my
laptop and wait for it to boot the installer......

All I did when grub came up was to hit enter. What is bizarre is that I
tried the same USB stick in another laptop and there it worked fine.

Comment 11 Brian Lane 2011-09-02 23:40:46 UTC

*** This bug has been marked as a duplicate of bug 728122 ***


Note You need to log in before you can comment on or make changes to this bug.