Bug 728122 - upgrade failed from f15 to f16, Dispatch error:cannot reschedule step 'language' from 'done' to 'scheduled'
upgrade failed from f15 to f16, Dispatch error:cannot reschedule step 'langu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 730166 731466 731695 735036 (view as bug list)
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-04 02:53 EDT by Hongqing Yang
Modified: 2014-09-30 19:40 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 17:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (9.56 KB, text/plain)
2011-08-04 02:53 EDT, Hongqing Yang
no flags Details
syslog (12.38 KB, text/plain)
2011-08-04 02:54 EDT, Hongqing Yang
no flags Details
program log (24.82 KB, text/plain)
2011-08-04 02:55 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-08-04 02:53:47 EDT
Created attachment 516623 [details]
anaconda.log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install fedora 15
2. boot from fedora 16
3. choose upgrade an existing installation
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-08-04 02:54:25 EDT
Created attachment 516624 [details]
syslog
Comment 2 Hongqing Yang 2011-08-04 02:55:33 EDT
Created attachment 516625 [details]
program log
Comment 3 Ales Kozumplik 2011-08-05 10:00:29 EDT
Hi, can you please retest with:
http://akozumpl.fedorapeople.org/bz_dispatcher.img

And see if it fixes the problem or attach the new traceback?

Thanks.
Comment 4 James Laska 2011-08-05 11:49:57 EDT
Proposing as a F16Beta release blocker per the following Beta release criteria ...
  "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria "
Comment 5 Hongqing Yang 2011-08-05 22:48:44 EDT
(In reply to comment #3)
> Hi, can you please retest with:
> http://akozumpl.fedorapeople.org/bz_dispatcher.img
> 
> And see if it fixes the problem or attach the new traceback?
> 
> Thanks.

The error message is the same with bug 728188, I would like to close this.

*** This bug has been marked as a duplicate of bug 728188 ***
Comment 6 Ales Kozumplik 2011-08-09 03:54:15 EDT
See the master patch c3bedc8c5b1542e882824d5fb4005f6336e7822a for a resolution of this issue specifically.
Comment 7 Hongqing Yang 2011-08-09 22:38:18 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > Hi, can you please retest with:
> > http://akozumpl.fedorapeople.org/bz_dispatcher.img
> > 
> > And see if it fixes the problem or attach the new traceback?
> > 
> > Thanks.
> 
> The error message is the same with bug 728188, I would like to close this.
> 
> *** This bug has been marked as a duplicate of bug 728188 ***


without the dispatch,  the errors are different, I will leave this open
until Beta to verify.
Comment 8 Ales Kozumplik 2011-08-12 08:55:40 EDT
*** Bug 730166 has been marked as a duplicate of this bug. ***
Comment 9 Chris Bagwell 2011-08-15 23:54:26 EDT
I ran upgrade from RC4 and still get this error message and failed upgrade. So I'm still not able to upgrade from Alpha release.

Did commit in comment 6 make it into RC4/anaconda 16.14.5?

anaconda 16.14.5 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 98, in _r
eschedule
    self.namesched(to_sched)))
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 148, in s
chedule
    return self._reschedule(self.SCHED_SCHEDULED, current_step)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in <
lambda>
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in s
chedule_steps
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 288, in se
tSteps
    "complete"
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/examine_gui.py", line 43,
 in getNext
    upgrade.setSteps(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1194, in nextC
licked
    rc = self.currentWindow.getNext ()
DispatchError: Can not reschedule step 'language' from 'skipped' to 'scheduled'
Comment 10 Ales Kozumplik 2011-08-16 02:03:12 EDT
No, it did not, please check again with post-alpha composes.
Comment 11 Ales Kozumplik 2011-08-18 05:28:12 EDT
*** Bug 731466 has been marked as a duplicate of this bug. ***
Comment 12 Jiri Moskovcak 2011-08-18 07:32:30 EDT
*** Bug 731695 has been marked as a duplicate of this bug. ***
Comment 13 Tim Flink 2011-09-01 13:22:42 EDT
Discussed in the 2011-08-26 blocker review meeting. Accepted as a Fedora 16 beta blocker as it violates the following beta release criterion [1]:

The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria.

[1] https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 14 Brian Lane 2011-09-02 19:40:46 EDT
*** Bug 735036 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2011-09-07 17:21:43 EDT
Hongqing, can you please confirm the status of this bug in Beta TC1? Thanks!
Comment 16 Trever Adams 2011-09-07 17:49:39 EDT
While I am not Hongqing, I can confirm this bug exists in Beata TC1.
Comment 17 Hongqing Yang 2011-09-08 01:59:00 EDT
(In reply to comment #15)
> Hongqing, can you please confirm the status of this bug in Beta TC1? Thanks!

(In reply to comment #16)
> While I am not Hongqing, I can confirm this bug exists in Beata TC1.

since the drucut error, I cannot boot F16 on both the desktops here. Thank Trever for the confirmation.
Comment 18 Ales Kozumplik 2011-09-08 02:31:28 EDT
(In reply to comment #16)
> While I am not Hongqing, I can confirm this bug exists in Beata TC1.

Hi,

can you please attach all /tmp/*log files you find after the crash in the installation ramdisk?

Thanks.
Comment 19 Trever Adams 2011-09-10 05:44:37 EDT
This bug is fixed in Beta TC2. Unfortunately, there is another bug that keeps it from completely installing.
Comment 20 Adam Williamson 2011-09-12 17:21:34 EDT
Confirmed Trever's result: this bug is fixed in TC2, and you run into https://bugzilla.redhat.com/show_bug.cgi?id=735730 later in install. Moving to CLOSED, as I'm pretty sure an anaconda with this fix in it already went stable.

Note You need to log in before you can comment on or make changes to this bug.