Bug 735037 - F16-Beta.TC1 - Yum update results in - "Check that the correct key URLs are configured for this repository" error message
Summary: F16-Beta.TC1 - Yum update results in - "Check that the correct key URLs are c...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard: RejectedBlocker
: 735235 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 09:09 UTC by Michal Nowak
Modified: 2014-03-17 03:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 03:36:31 UTC


Attachments (Terms of Use)
full yum output (323.54 KB, text/plain)
2011-09-01 09:09 UTC, Michal Nowak
no flags Details
Yet another full yum output (slightly smaller) (111.71 KB, text/plain)
2011-09-01 17:18 UTC, Nils Philippsen
no flags Details
"yum -y --skip-broken --verbose" (1001.38 KB, text/plain)
2011-09-01 17:24 UTC, Nils Philippsen
no flags Details

Description Michal Nowak 2011-09-01 09:09:56 UTC
Created attachment 520979 [details]
full yum output

Description of problem:

With today's bunch of updates I am unable to update:

Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 069c8460: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64


The GPG keys listed for the "Fedora 16 - x86_64" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.


Version-Release number of selected component (if applicable):

fedora-release-16-0.9.noarch

How reproducible:

always

Comment 1 Robert Lightfoot 2011-09-01 12:09:35 UTC
F16-Beta.TC1-i386-DVD.iso also suffers from this malady when yum update was run.

Comment 2 Elad Alfassa 2011-09-01 12:16:18 UTC
Proposing as a beta blocker,

Criteria: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops" from http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria 




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Kevin Bush 2011-09-01 14:32:59 UTC
Also see this error after a Fedora 16 alpha x86_64 DVD install.

Thanks,

Kevin

Comment 4 Adam Williamson 2011-09-01 16:54:25 UTC
The yum log doesn't seem complete, it just ends without including the message mentioned in the bug summary. Could someone post a full yum output capture? thanks.

Comment 5 Nils Philippsen 2011-09-01 17:18:09 UTC
Created attachment 521060 [details]
Yet another full yum output (slightly smaller)

Comment 6 Nils Philippsen 2011-09-01 17:24:16 UTC
Created attachment 521062 [details]
"yum -y --skip-broken --verbose"

Comment 7 Adam Williamson 2011-09-01 17:31:12 UTC
can you try skipping btrfs-progs ? I believe this is the issue discussed on the devel list, thread "yum update btrfs-progs failing on F16alpha".

Comment 8 Lars W 2011-09-01 17:52:18 UTC
>> can you try skipping btrfs-progs ?

That did the trick for me. Thanks!

Comment 9 Robert Lightfoot 2011-09-01 18:28:35 UTC
--exclude=btrfs-progs worked on my x86_64 install and did not result in this error which had been there previous.

Comment 10 Adam Williamson 2011-09-01 18:42:50 UTC
Dennis says he's re-signed this (and any other stray f15 inherits) this morning, so the problem should go away as the re-sign gets out to mirrors. He's going to turn f15->f16 inheritance off now too.

Comment 11 Nils Philippsen 2011-09-01 18:46:15 UTC
This workaround did it for me as well.

Note to self: Would be nice if yum told you what package exactly shows this problem...

Comment 12 satellitgo 2011-09-02 01:02:49 UTC

yum update for Fedora-16-Beta-TC-i686-Live-XFCE.iso

warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 069c8460: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386


The GPG keys listed for the "Fedora 16 - i386" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository

Comment 13 Adam Williamson 2011-09-02 18:06:51 UTC
Discussed at 2011-09-02 blocker review meeting. Agreed that this is not a blocker: the upgrade criterion is intended to check that yum and PK behave as intended, not that there are no problematic packages available in the update repository, which may happen transiently at any time. FWIW, it should be fixed already, as dgilmore has resigned the offending package; it will take a bit of time to sync out to mirrors, though. if this is still happening in a few days dgilmore will check it again.

Comment 14 Barry Fishman 2011-09-03 14:37:51 UTC
*** Bug 735235 has been marked as a duplicate of this bug. ***

Comment 15 satellitgo 2011-09-14 00:58:26 UTC
yum update works in f16 live desktop TC2.
This bug does not appear here

Comment 16 Robert Lightfoot 2011-09-14 03:36:31 UTC
Marking as closed - works for me base on satellit's testing and mine.  Looks like this was an error in updates released which has been addressed in recent versions.


Note You need to log in before you can comment on or make changes to this bug.