Bug 735235 - Upgrade fails on transaction error
Summary: Upgrade fails on transaction error
Keywords:
Status: CLOSED DUPLICATE of bug 735037
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 21:18 UTC by Barry Fishman
Modified: 2014-01-21 23:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-03 14:37:51 UTC


Attachments (Terms of Use)
Log from yum update --skip-broken (22.50 KB, text/plain)
2011-09-01 21:31 UTC, Barry Fishman
no flags Details

Description Barry Fishman 2011-09-01 21:18:23 UTC
Description of problem:
When I try to update with Software Update or Yum I get a popup
that says:

Transaction error 
The GPG keys listed for the "Fedora 16 - x86_64" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

Was attempting to update the 2011-08-29 and 2011-08-18 changes.
Previous attempts stalled because of missing packages

Version-Release number of selected component (if applicable):

Fedora 16 installed from alpha

How reproducible:

Always.  I tried a 'yum clean all' and restarting with no effect

Steps to Reproduce:
1. Run software update or yum
2.
3.
  
Actual results:
as described.

Expected results:

At least some information about what package failed so I could uninstall it.

Additional info:

Fedora 15 runs fine.

Comment 1 Barry Fishman 2011-09-01 21:31:48 UTC
Created attachment 521105 [details]
Log from yum update --skip-broken

I've add the output when I run yum.

Comment 2 Barry Fishman 2011-09-02 19:14:28 UTC
This seems to be the same as bug #735037, which I discovered later.  There seems to be a long delay between filing a but and it showing up.  There seems to be no way for original submitters to merge there bug reports with that of previous reports they discovered later.

I ran the 'Software Update' application and it failed again with the same bug.  I then ran 'yum update --verbose --skip-broken and it succeeded.

I then did another 'yum update --skip-broken' and a few more updates happened.

Now "Software Update' runs without signaling a an error.  Of course, there are still packages that don't update due to missing dependencies.

Comment 3 Barry Fishman 2011-09-03 14:37:51 UTC
Seem to be the same as a previous bug report, which seems to have
been resolved.

*** This bug has been marked as a duplicate of bug 735037 ***


Note You need to log in before you can comment on or make changes to this bug.