Bug 735073 - QEMU/KVM live migration with non-shared storage expects an image file on destination
Summary: QEMU/KVM live migration with non-shared storage expects an image file on dest...
Keywords:
Status: CLOSED DUPLICATE of bug 967233
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 11:03 UTC by Henrik Ahlgren
Modified: 2013-05-25 20:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-25 20:49:59 UTC


Attachments (Terms of Use)

Description Henrik Ahlgren 2011-09-01 11:03:41 UTC
Description of problem:

QEMU/KVM live migration on non-shared storage using --copy-storage-all fails with error message "error: unable to set user and group to '(UID):(GID)' on '/PATH/TO/IMAGE': No such file or directory" if the image file is not created
in advance on the destination host. In case an empty image with identical path is created manually using "qemu-img create", the migration succeeds. Note however, simply creating an empty file with touch(1) is not enough, it 
needs to be a qemu supported image file (I've tested with qcow2).

I think this is unexpected (undocumented at least) behavior --libvirt (or qemu?) should create an empty image if it does not exists already. OTOH, if it does, maybe it should even warn the user before overwriting it?

Version-Release number of selected component (if applicable):

libvirt 0.9.4 (from Debian Experimental)
qemu-kvm 0.15 (from Debian Experimental)

How reproducible:

Always.

Steps to Reproduce:
1. migrate --live --verbose --copy-storage-all DOMAIN qemu+ssh://DESTHOST/system
  
Actual results:

error: unable to set user and group to '107:107' on '/data/vm/ahlghe-test2.qcow2': No such file or directory

Expected results:

Disk image created, it's content copied and virtual machine migrated.

Additional info:

Comment 1 Cole Robinson 2013-05-25 20:49:59 UTC

*** This bug has been marked as a duplicate of bug 967233 ***


Note You need to log in before you can comment on or make changes to this bug.