Bug 967233 - RFE: Add a migration flag to auto-create storage stubs on the destination
RFE: Add a migration flag to auto-create storage stubs on the destination
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Privoznik
:
: 735073 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 16:49 EDT by Cole Robinson
Modified: 2014-12-09 11:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-09 11:05:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-05-25 16:49:36 EDT
Doing 'virsh migrate --copy-storage-all' currently isn't very end user friendly because it requires initial stub storage files to exist on the destination host. 

Trying to automatically do this is likely difficult and error prone given all the possible storage configurations available, but IMO as is the feature is pretty uninteresting to end users.

I think we should add a migration API flag that will have the destination libvirt create storage stubs for disk images, if required. Even if a first attempt just handles image files that would go a long way.

Without this, we would _have_ to implement something similar just to expose this in virt-manager, so IMO it's better to do this at the libvirt level first, so all clients (particularly virsh) can benefit.
Comment 1 Cole Robinson 2013-05-25 16:49:59 EDT
*** Bug 735073 has been marked as a duplicate of this bug. ***
Comment 2 Michal Privoznik 2013-05-27 00:58:56 EDT
There's a RHEL bug requsting the same 927252.
Comment 3 Michal Privoznik 2014-12-09 11:01:53 EST
So, the patches are upstream (see https://bugzilla.redhat.com/show_bug.cgi?id=927252#c9 ). There's no special flag added. The storage will be precreated automatically, if user hasn't done it. Cole is that enough to close this bug?
Comment 4 Cole Robinson 2014-12-09 11:05:31 EST
Yeah I saw those patches go by, thanks a lot! I still need to test it out but regardless this bug is solved, if I hit any issues ill open separate reports

Note You need to log in before you can comment on or make changes to this bug.