Bug 73513 - wordtrans-web uses obsoleted PHP script style
Summary: wordtrans-web uses obsoleted PHP script style
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wordtrans (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 77450 (view as bug list)
Depends On: 73516
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-05 16:19 UTC by Joe Orton
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-04 09:37:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2002-09-05 16:19:13 UTC
The PHP scripts in /var/www/html/wordtrans/ use the obsoleted PHP script
delimiters <?  ?> which don't work by default with the version of PHP currently
in Raw Hide: <?php ... ?> has to be used instead.

Comment 1 Gary Benson 2002-09-05 16:43:25 UTC
This should be fixable by creating the file /etc/httpd/conf.d/wordtrans.conf and
making it contain the following:

  <Directory /var/www/html/wordtrans>
      php_value short_open_tag 1
  </Directory>

However this does not work at present due to bug 73516.


Comment 2 Ngo Than 2002-09-05 18:59:43 UTC
Bryce, do you know why does php use new style ?php as default.
It will break the old php scripts?

Comment 3 Joe Orton 2002-11-07 09:49:59 UTC
It will, and it does, but it was done.

Comment 4 Joe Orton 2002-11-07 09:52:56 UTC
*** Bug 77450 has been marked as a duplicate of this bug. ***

Comment 5 Ngo Than 2002-11-07 12:31:20 UTC
the bug 73516 is still there, this means that /etc/httpd/conf.d/wordtrans.conf
will does not work and i have to fix php scripts?



Comment 6 Joe Orton 2002-12-04 09:36:15 UTC
Adding "Requires: php >= 4.2.2-10" to wordtrans-web and using:

  <Directory /var/www/html/wordtrans>
      php_admin_flag short_open_tag Off
  </Directory>

will work now.

Comment 7 Joe Orton 2002-12-04 09:37:00 UTC
That should be "php_admin_flag short_open_tag On", of course...

Comment 8 Ngo Than 2002-12-04 15:45:52 UTC
it's fixed in wordtrans-1.1pre9-11. Thanks for your infos.


Note You need to log in before you can comment on or make changes to this bug.