Bug 735296 - [RFE] update mingw32-boost to 1.46.1
Summary: [RFE] update mingw32-boost to 1.46.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-boost
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Thomas Sailer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 08:25 UTC by Haïkel Guémar
Modified: 2011-09-14 22:40 UTC (History)
4 users (show)

Fixed In Version: mingw32-boost-1.46.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 22:40:09 UTC


Attachments (Terms of Use)
compilation failure test case (361 bytes, text/x-c++src)
2011-09-02 08:25 UTC, Haïkel Guémar
no flags Details

Description Haïkel Guémar 2011-09-02 08:25:28 UTC
Created attachment 521171 [details]
compilation failure test case

Description of problem: the provided mingw32-boost 1.46.0 is buggy, 
Version-Release number of selected component (if applicable): 1.46.0
How reproducible: always

Steps to Reproduce:
1. compile any source code using property_tree using json parser with mingw32 cross-compiler.
  
Actual results: compilation failure when using property_tree library

Expected results: compilation of the aforementioned goes fine

Additional info: 1.46.1 release fixes that issue among others

I attached a sample test case, that compiles fine using native compiler environment (boost 1.46.1) and fails with cross-compiler environment (boost 1.46.0)

g++ compilation-failure-mingw32-json.cc
i686-pc-mingw32-g++ compilation-failure-mingw32-json.cc

Comment 1 Fedora Update System 2011-09-02 09:07:45 UTC
mingw32-boost-1.46.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mingw32-boost-1.46.1-1.fc15

Comment 2 Thomas Sailer 2011-09-02 09:16:47 UTC
Which "native compiler environment"?

We don't ship boost 1.46.1 on FC15... (there used to be a koji build that's now deleted)

Comment 3 Haïkel Guémar 2011-09-02 12:25:57 UTC
Sorry, i had rebuilt 1.47 package on FC15 for another software project. I might also file a ticket for package boost.

Comment 4 Thomas Sailer 2011-09-02 13:29:43 UTC
Please do. Also, if the newly built package above works for you, then please add some karma.

Comment 5 Haïkel Guémar 2011-09-02 14:29:42 UTC
I previously rebuilt f16 1.36.1 package and it worked fine. The current update fixes the issue. Thank you !

Comment 6 Denis Arnaud 2011-09-04 13:58:27 UTC
(In reply to comment #3)
> Sorry, i had rebuilt 1.47 package on FC15 for another software project. I might
> also file a ticket for package boost.

Just for the sake of reference, bug 735344 has opened, and closed, because the issue was in fact fixed as a (Fedora packaging) patch of Boost-1.46.0, referenced by bug 715611.

Comment 7 Fedora Update System 2011-09-07 00:12:22 UTC
Package mingw32-boost-1.46.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mingw32-boost-1.46.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mingw32-boost-1.46.1-1.fc15
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-09-14 22:40:04 UTC
mingw32-boost-1.46.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.