Bug 735344 - [RFE] update boost to 1.46.1
Summary: [RFE] update boost to 1.46.1
Keywords:
Status: CLOSED DUPLICATE of bug 715611
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 12:37 UTC by Haïkel Guémar
Modified: 2013-08-09 05:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 14:57:30 UTC


Attachments (Terms of Use)

Description Haïkel Guémar 2011-09-02 12:37:20 UTC
I filed a similar ticket against mingw32-boost, boost 1.46.0 has some flaws that makes some libraries like property_tree unusable.
https://bugzilla.redhat.com/show_bug.cgi?id=735296

I did not detect initially the problem with native packages since i use updated packages for another software project.

Comment 1 Petr Machata 2011-09-02 14:13:30 UTC
That is potentially problematic, as we have a bunch of stuff built against boost 1.46.0 in Fedora 15.  Since boost claims no API or ABI stability, we cannot simply dump the new release.

We can fix individual bugs though.  I tried the reproducer that you attached to bug 735296, and it all works for me.  What problems do you have in particular with the boost that we ship?

Comment 2 Haïkel Guémar 2011-09-02 14:57:30 UTC
Looks like that it was already fixed in this commit:
http://pkgs.fedoraproject.org/gitweb/?p=boost.git;a=commit;h=f4262d65025488b2cf79ebcdcbc7d0dd40b17b0d

Sorry for disturbing you (i closed the ticket as a duplicate of previous ticket)

*** This bug has been marked as a duplicate of bug 715611 ***


Note You need to log in before you can comment on or make changes to this bug.