Bug 735437 - Kernel stops working since version 2.6.40-x | kernel BUG at drivers/media/media-entity.c:346!
Kernel stops working since version 2.6.40-x | kernel BUG at drivers/media/med...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
AcceptedNTH
:
: 734963 (view as bug list)
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2011-09-02 11:52 EDT by Steve
Modified: 2011-10-05 19:58 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-2.6.40.6-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-11 23:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shot1 (4.69 MB, image/jpeg)
2011-09-02 11:52 EDT, Steve
no flags Details
Shot2 (4.84 MB, image/jpeg)
2011-09-02 11:54 EDT, Steve
no flags Details
Output of: # rpm -i kernel-2.6.40.4-5.fc15.x86_64.rpm (1.73 KB, application/octet-stream)
2011-09-06 11:10 EDT, Steve
no flags Details
Shot3 (4.96 MB, image/jpeg)
2011-09-06 12:54 EDT, Steve
no flags Details
Shot4 (4.55 MB, image/jpeg)
2011-09-06 13:27 EDT, Steve
no flags Details
Shot5 (4.63 MB, image/jpeg)
2011-09-06 13:30 EDT, Steve
no flags Details
Shot6 (4.54 MB, image/jpeg)
2011-09-06 13:34 EDT, Steve
no flags Details

  None (edit)
Description Steve 2011-09-02 11:52:31 EDT
Created attachment 521257 [details]
Shot1

Description of problem:
Kernel stops working since version 2.6.40-x on Dell Inspiron 15 N5040

Version-Release number of selected component (if applicable):
kernel-2.6.40.3-0.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:


Expected results:
Kernel should boot up as in versions before 

Additional info:
Screen-shots attached
Comment 1 Steve 2011-09-02 11:54:36 EDT
Created attachment 521258 [details]
Shot2
Comment 2 Josh Boyer 2011-09-06 10:36:16 EDT
There's a similar report in Debian.  I've started a scratch kernel with the debug patch applied from there.  Could you please install it and attached the kernel output when the build completes?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3327228
Comment 3 Steve 2011-09-06 11:10:14 EDT
Created attachment 521684 [details]
Output of: # rpm -i kernel-2.6.40.4-5.fc15.x86_64.rpm
Comment 4 Josh Boyer 2011-09-06 11:22:53 EDT
(In reply to comment #3)
> Created attachment 521684 [details]
> Output of: # rpm -i kernel-2.6.40.4-5.fc15.x86_64.rpm

1) That isn't the right kernel.  You need the kernel with the debug patch, which is the one pointed to by the URL in comment #2 and is still building.

2) We need the output of dmesg or the oops output on boot, not the RPM output.
Comment 5 Steve 2011-09-06 11:33:00 EDT
Understood, will wait and look for that kernel..
Comment 6 Steve 2011-09-06 12:54:46 EDT
Created attachment 521713 [details]
Shot3

Ok, i installed kernel-debug-2.6.40.4-5.1.fc15.x86_64.rpm. The oops are the same as in https://bugzilla.redhat.com/show_bug.cgi?id=735437#c0. I can not boot up also this kernel. The picture attached shows the last state were the kernel is hanging.
Comment 7 Josh Boyer 2011-09-06 13:04:28 EDT
There should be a line printed out that looks like:

"connecting <something> to <something>

before the kernel oops output similar to what you captured in the picture in comment #1.  Can you tell us what that says?
Comment 8 Steve 2011-09-06 13:27:01 EDT
Created attachment 521716 [details]
Shot4

Sorry, i cannot find this line. Here are the pictures..
Comment 9 Steve 2011-09-06 13:30:50 EDT
Created attachment 521718 [details]
Shot5
Comment 10 Steve 2011-09-06 13:34:14 EDT
Created attachment 521719 [details]
Shot6
Comment 11 Josh Boyer 2011-09-06 13:44:25 EDT
If you add ignore_loglevel to the kernel command line, does that line show up?
Comment 12 Steve 2011-09-06 14:01:21 EDT
Yep:

connecting (null)(0):0(/0) to Extension 7(0):0(/2)
Comment 13 Adam Williamson 2011-09-06 15:05:10 EDT
*** Bug 734963 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2011-09-06 15:05:37 EDT
proposing as NTH.
Comment 15 Josh Boyer 2011-09-07 09:34:46 EDT
This build has a patch from upstream that is expected to fix the issue.  When the build completes, could you please test it out and let us know if it works?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3332371
Comment 16 Steve 2011-09-07 11:21:42 EDT
kernel-debug-2.6.40.4-5.2.fc15.x86_64.rpm is working for me.
Comment 17 Steve 2011-09-07 11:33:09 EDT
(In reply to comment #16)
> kernel-debug-2.6.40.4-5.2.fc15.x86_64.rpm is working for me.

kernel-2.6.40.4-5.2.fc15.x86_64.rpm  also.
Comment 18 Josh Boyer 2011-09-07 12:45:41 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > kernel-debug-2.6.40.4-5.2.fc15.x86_64.rpm is working for me.
> 
> kernel-2.6.40.4-5.2.fc15.x86_64.rpm  also.

Thank you very much for the debug and test effort.  I've committed the fix to the fedora repository and it will be included in the next official build for f15, f16, and rawhide.
Comment 19 Steve 2011-09-07 13:14:47 EDT
I thank You!
Comment 20 Adam Williamson 2011-09-08 12:50:49 EDT
Josh, could do you a new F16 build + update fairly soon, so we can make sure to pull this into Beta? Thanks!
Comment 21 Josh Boyer 2011-09-08 13:21:19 EDT
(In reply to comment #20)
> Josh, could do you a new F16 build + update fairly soon, so we can make sure to
> pull this into Beta? Thanks!

There's a PCI regression/bug being worked on upstream.  A user has indicated that it's causing 734201 for him.  I'm waiting for a fix to materialize there before I do another build.  Hopefully later today/tomorrow.
Comment 22 Marcin Zajaczkowski 2011-09-08 14:27:16 EDT
Confirmed to work with Asus N43S (bug 734963). Thanks.
Comment 23 Fedora Update System 2011-09-09 11:42:59 EDT
kernel-3.1.0-0.rc5.git0.0.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc5.git0.0.fc16
Comment 24 Adam Williamson 2011-09-09 14:27:28 EDT
Discussed at 2011-09-09 blocker review meeting. Accepted as Beta NTH as this causes affected systems not to boot, which obviously can't be fixed post-release.
Comment 25 Fedora Update System 2011-09-10 14:56:39 EDT
Package kernel-3.1.0-0.rc5.git0.0.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.0-0.rc5.git0.0.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc5.git0.0.fc16
then log in and leave karma (feedback).
Comment 26 matanya 2011-09-11 02:59:59 EDT
Confirmed to work with Asus k53e-b1. thanks!
Comment 27 Fedora Update System 2011-09-11 23:41:55 EDT
kernel-3.1.0-0.rc5.git0.0.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2011-10-04 10:14:42 EDT
kernel-2.6.40.6-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.6-0.fc15
Comment 29 Fedora Update System 2011-10-05 19:58:47 EDT
kernel-2.6.40.6-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.