Bug 734963 - scsi_wait_scan hangs, possibly because of udev timeout looking at video0
Summary: scsi_wait_scan hangs, possibly because of udev timeout looking at video0
Keywords:
Status: CLOSED DUPLICATE of bug 735437
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F16Beta-accepted, F16BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-08-31 23:29 UTC by Marcin Zajaczkowski
Modified: 2011-10-04 04:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 19:05:10 UTC


Attachments (Terms of Use)
anaconda.log (2.25 KB, text/plain)
2011-09-01 18:55 UTC, Marcin Zajaczkowski
no flags Details
program.log (493 bytes, text/plain)
2011-09-01 18:55 UTC, Marcin Zajaczkowski
no flags Details
storage.log (5.63 KB, text/plain)
2011-09-01 18:56 UTC, Marcin Zajaczkowski
no flags Details
grepped messages.log (139.68 KB, text/plain)
2011-09-01 19:08 UTC, Marcin Zajaczkowski
no flags Details

Description Marcin Zajaczkowski 2011-08-31 23:29:42 UTC
Description of problem:
Anaconda hangs at "examining storage devices" (just after keyboard layout selection).

Version-Release number of selected component (if applicable):
16.16-1

How reproducible:
Always

Steps to Reproduce:
1. Run LiveCD
2. Run Install to Hard Drive
3. Next, Install anyway, Next
  
Actual results:
Anaconda hangs at "examining storage devices".

Expected results:
Ability to select partition layout.


Additional info:
Installation Fedora 16 Alpha also 16 Beta TC1 (both x86_64) from livecd with Gnome on the Asus N43S laptop with a clean 750GB SATA disk. It seems to be similar to Bug 728883 but I don't have mentioned stack trace (when started from a console I see only info about loading us.map.gz). I the same moment I've got message about SELinux (SELinux is preventing /usr/libexec/udisks-daemon from getettr access on the file /osmin). I set SELinux to permissive mode, but anaconda hangs anyway in the another run. I tried to update anaconda, udisks and selinux-policy, but without any change.

Selecting Specialized Storage Devices also hangs, but at the same page (with Basic Storage Device there is another page with mentioned message).

Comment 1 David Lehman 2011-09-01 00:07:11 UTC
Please attach the following log files as attachments of type text/plain:

  /tmp/anaconda.log
  /tmp/program.log
  /tmp/storage.log
  /var/log/messages

Comment 2 Marcin Zajaczkowski 2011-09-01 18:55:08 UTC
Created attachment 521079 [details]
anaconda.log

Comment 3 Marcin Zajaczkowski 2011-09-01 18:55:47 UTC
Created attachment 521080 [details]
program.log

Comment 4 Marcin Zajaczkowski 2011-09-01 18:56:32 UTC
Created attachment 521081 [details]
storage.log

Comment 5 Marcin Zajaczkowski 2011-09-01 19:08:38 UTC
Created attachment 521082 [details]
grepped messages.log

message.log with repeating every second line;
Sep  1 17:09:09 localhost udevd[494]: timeout: killing 'usb_id --export /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/video4linux/video0' [804]
grepped out.

Comment 6 Marcin Zajaczkowski 2011-09-01 19:15:23 UTC
When I start "Install to Hard Drive" first time nothing visually happened. There was a process running:
root      1744  0.0  0.2 462164 20408 ?        Sl   16:37   0:00 /usr/bin/python /usr/bin/anaconda-cleanup anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8

After a few minutes I killed it with SIGTERM and then GUI appeared. Before that anaconda.log was empty, program.log has only one line:
16:37:44,876 INFO program: Running... modprobe scsi_wait_scan
storage.log was the same as attached.

I you need something more to track the problem or have any idea how to get Fedora 16 installed on hard drive please let me know.

Comment 7 David Lehman 2011-09-01 19:18:22 UTC
Try running modprobe scsi_wait_scan as root from a shell and see if it hangs for several minutes. I expect it will.

Comment 8 David Lehman 2011-09-01 19:27:54 UTC
It may be that your udev timeout trying to handle your video0 device is preventing the scsi wait scan from running.

Comment 9 Marcin Zajaczkowski 2011-09-01 19:33:57 UTC
And it is.

Any workaround suggestion? I'm just hanging on fedora-qa IRC channel in case you would like to check something in real time (nick: Szpak).

Comment 10 David Lehman 2011-09-01 20:04:18 UTC
I'm not sure if this is a udev problem or something further down. I'm just passing it along to get it closer to the appropriate component.

Comment 11 Marcin Zajaczkowski 2011-09-01 20:25:46 UTC
It can be a good shot with video0. modprobe -r uvcvideo hangs as well. There is also a stack in messages.log:

[   59.028698] Linux media interface: v0.10
[   60.549832] Linux video capture interface: v2.00
[   61.463558] uvcvideo: Found UVC 1.00 device USB2.0 UVC 2M WebCam (13d3:5205)
[   61.483911] ------------[ cut here ]------------
[   61.485900] kernel BUG at drivers/media/media-entity.c:346!
[   61.487871] invalid opcode: 0000 [#1] SMP 
[   61.489824] CPU 0 
[   61.489842] Modules linked in: uvcvideo(+) snd_seq_device ath9k_common ath9k_hw videodev snd_pcm media ath btusb snd_timer v4l2_compat_ioctl32 asus_nb_wmi snd bluetooth asus_wmi cfg80211 soundcore sparse_keymap snd_page_alloc rfkill iTCO_wdt atl1c i2c_i801 iTCO_vendor_support microcode serio_raw joydev uinput squashfs i915 nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
[   61.498257] 
[   61.500336] Pid: 744, comm: modprobe Not tainted 3.1.0-0.rc3.git0.0.fc16.x86_64 #1 ASUSTeK Computer Inc. N43SN/N43SN
[   61.502509] RIP: 0010:[<ffffffffa0225d7d>]  [<ffffffffa0225d7d>] media_entity_create_link+0x31/0xe3 [media]

I could blacklist that module, but it's a livecd. I tried anaconda boot switch blacklist=uvcvideo [1], but module is still loaded.

[1] - http://fedoraproject.org/wiki/Anaconda_Boot_Options

Can I prevent that module from loading with boot parameter or I need to customize livecd to add entry to /etc/modprobe.d/blacklist.conf ?

Comment 12 Harald Hoyer 2011-09-01 21:22:50 UTC
kernel bug

Comment 13 Marcin Zajaczkowski 2011-09-01 21:41:58 UTC
Looks exactly as http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=637740

Btw, Harold, I've just found that you wrote something about rd.blacklist:
http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=commitdiff_plain;h=2d9f5858bc0bb61feb06ae0385078bac4debc82b

Should rd.blacklist=uvcvideo as boot parameter work in Fedora 16 Beta TC1 (I tried it, but module it still loaded)?

Comment 14 Marcin Zajaczkowski 2011-09-01 21:42:40 UTC
Harold -> Harald (sorry)

Comment 15 Marcin Zajaczkowski 2011-09-05 20:24:44 UTC
It seems rd.blacklist works only in the first booting phrase and /etc/modprobe.d/blacklist.conf is needed anyway. With modified LiveCD I was able to perform installation.

Btw, maybe it should be mentioned as common bug? With that bug in kernel anyone with that model of web camera want be able to work normally with F16.

Comment 16 Adam Williamson 2011-09-06 19:00:38 UTC
in the Debian bug, the dev is looking for result with a patch:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=637740#27

it might help for you to do that, Marcin.

Comment 17 Adam Williamson 2011-09-06 19:01:06 UTC
proposing this as NTH at least.

Comment 18 Adam Williamson 2011-09-06 19:05:10 UTC
this is a dupe of 735437 - that one actually came later, but it has more useful info and a developer response.

*** This bug has been marked as a duplicate of bug 735437 ***


Note You need to log in before you can comment on or make changes to this bug.