Bug 73567 - gnome-terminal does not get along with "screen" very well
gnome-terminal does not get along with "screen" very well
Status: CLOSED DUPLICATE of bug 73218
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 01:02 EDT by Michael Lee Yohe
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 01:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2002-09-06 01:02:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
If you use screen with gnome-terminal, the text will refuse to scroll up in the
terminal window allowing you to see new contents.  Instead, the last line in the
terminal window will update while the old contents will continue to sit in the 1
through N-1 lines of the terminal window.

Strange, however - "top" seems to be unaffected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a new terminal window.
2. Start a "screen" session.
3. Fill the screen up with something (hitting Enter and filling it up with
prompts will suffice).
4. Type "echo Hello" at the prompt.

	

Actual Results:  You will see a new prompt on the last line but no evidence of
the "Hello" that was supposed to be echoed.

Expected Results:  "Hello" was to be printed out on its own line.  A new prompt
should then have been printed out in the bottom line.

Additional info:

gnome-terminal is up2date (version is 2.0.1-3)

gnome-terminal 2.0 is very nice (the tabbed interface was a very smart idea). 
However, it would really be nice to have gnome-terminal 1.4 as an alternative
since it inherently will not use anti-aliased fonts and seemed to be rock solid
as far as usability is concerned.
Comment 1 Havoc Pennington 2002-09-06 01:23:38 EDT
(if you don't want aa fonts, just choose a bitmap font - lucidatypewriter is the
one we include. or you can turn off aa for all apps in Preferences->Fonts)
Comment 2 Michael Lee Yohe 2002-09-06 01:27:45 EDT
This bug was directly related to Bug 73218 - the new vte package 0.8.13 corrects
this problem too.

*** This bug has been marked as a duplicate of 73218 ***

Note You need to log in before you can comment on or make changes to this bug.