Bug 73218 - In gnome-terminal, less fails to display file contents
In gnome-terminal, less fails to display file contents
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 73409 73564 73567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 20:50 EDT by Joe Christy
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 23:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Christy 2002-08-31 20:50:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
Instead of displaying file contents, less shows a single character

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open a file with less, or pipe a command through less
	

Actual Results:  less displays a single character. The character depends
deterministically on the file contents, i.e. invoking less on the same file
always gives the same character. Interestingly, cat-ing the file to a pipe to
less gives the same character as well.

Expected Results:  less displays a screenful of the file contents or the
beginning of the output of the command piped to it.

Additional info:

The system was installed yesterday and up2date-ed today, 8/31/02

The following are the contents of /etc/sysconfig/i18n:

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="LatArCyrHeb-16"
SYSFONTACM="utf8"
Comment 1 Tim Clymo 2002-09-01 13:21:16 EDT
I fixed this by upgrading to vte-0.8.13-1 from rawhide
Comment 2 Need Real Name 2002-09-02 02:04:59 EDT
This kinda makes it hard to read man pages. However a simple fix is to:
export LESS=-c

I currently have this line in my .bashrc as a workaround.
Comment 3 Nalin Dahyabhai 2002-09-02 13:02:54 EDT
charlesrazzell: Please check if updating to the version of vte in Raw Hide fixes
this or not, as I'm fairly certain that this bug is already fixed.
Comment 4 Damien Miller 2002-09-03 04:14:44 EDT
vte-0.8.13-1 fixes this bug for me.
Comment 5 Joe Christy 2002-09-03 12:23:02 EDT
Today's (9/3/02) up2date fixed the problem for me.
Comment 6 Nalin Dahyabhai 2002-09-05 15:36:18 EDT
*** Bug 73409 has been marked as a duplicate of this bug. ***
Comment 7 Michael Lee Yohe 2002-09-06 01:23:28 EDT
*** Bug 73564 has been marked as a duplicate of this bug. ***
Comment 8 Michael Lee Yohe 2002-09-06 01:27:39 EDT
*** Bug 73567 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.