Bug 735831 - missing /dev/stderr in init scripts
missing /dev/stderr in init scripts
Status: CLOSED DUPLICATE of bug 735618
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-05 12:16 EDT by Mads Kiilerich
Modified: 2014-03-16 23:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-05 23:25:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-09-05 12:16:40 EDT
These boot time errors popped up:

[   14.370565] fedora-readonly[526]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   14.794643] fedora-storage-init[706]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   16.754198] fedora-storage-init[901]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   17.622258] fedora-autoswap[915]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address

I guess they are caused by recent changes to systemd and stdout/stderr logging so processes no longer inherit stderr and /dev/stderr -> /proc/self/fd/2 thus no longer exists.

initscripts-9.32-1.fc16.x86_64
systemd-35-1.fc16.x86_64
Comment 1 Mads Kiilerich 2011-09-05 12:22:44 EDT
See also Bug 735832 for openssh keygen.
Comment 2 Bill Nottingham 2011-09-05 23:25:39 EDT

*** This bug has been marked as a duplicate of bug 735618 ***

Note You need to log in before you can comment on or make changes to this bug.