Bug 73586 - GRUB boot failure on Asus A7N266-VM
GRUB boot failure on Asus A7N266-VM
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 74686 78436 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 08:12 EDT by Toralf
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2002-09-06 08:12:23 EDT
Description of Problem:
I also have problems with grub on my A7N266-VM based setup (see bug 73339);
kernel load exits with memory error.

Version-Release number of selected component (if applicable):
0.91-4

How Reproducible:
Every time

Steps to Reproduce:
1. Install the OS select GRUB as boot loader (the default)
2. Start the system

Actual Results:
28 : Selected item cannot fit into memory

Expected Results:
The system boots.

Additional Information:
Fortunately, the system starts just fine from "syslinux" boot floppy or using
LILO on the hard drive.

Could this have something to do with the board's shared memory layout?
Comment 1 Need Real Name 2002-09-06 13:03:27 EDT
I have been directed here by Red Hat tech support. I'm using an Intel 
motherboard, D850EMV2, 256 MB Kingston RDRAM, Adaptec 29160N SCSI host adapter 
and three Seagate Ultra 160 hard drives. The first drive is quadri-partitioned, 
all primaries, with boot manager, System Commander, on the first partition 
followed thereafter by PC-DOS on the second, WIndows 98SE on the third and 
Windows 2000 on the fourth. The second drive is dedicated to SuSE Linux 8.0 
which is booted by Lilo installed into the MBR on the first drive and activated 
by the System Commander boot menu. Red Hat 7.3 has been installed on the third 
drive but will not boot either by installing Grub (1) on the MBR of the first 
drive or (2) into a first /boot partition on the third drive. System Commander 
will activate Grub but, once activated, the Grub will show it's menu, will time 
down to initiate Red Hat and then hang, showing Error 28: Selected item will 
not fit into memory. Unlike the preceeding entry, however, Lilo acts similarly: 
After being initiated by System Commander and showing its graphical interface, 
it simply times down to select Red Hat, shows "Loading Linux .." on a black 
screen and hangs with cursor blinking. 

It is important to point out that I have successfuly installed Mandrake 8.2 on 
this third drive and can boot it without difficulty. Neither have I had any 
difficulty booting SuSE 8.0 on the second drive. The problem seems to be quite 
specifically related to this machine and Red Hat 7.3 because I can sucessfully 
install and boot Red Hat 7.3 on an older machine I have which uses an Intel 
AL440LX board and a PII processor. Further, I should report that I have had the 
same problem booting your latest Beta, Null so-called. I'm disappointed; I very 
much would like to have a properly functioning Red Hat 7.3. 

John Lowell
Comment 2 Patrick Brand 2002-09-12 00:14:52 EDT
I have an ASUS A7n266E BIOS 1001d motherboard which worked with grub.  After
installing the latest BIOS 1003 grub gets an Error 28.  I suspect its because
grub is only reporting 512k of lower memory?  I also tried the latest beta
(null) and recieved the same results.
Comment 3 Jeremy Katz 2002-09-20 17:02:19 EDT
Probably -- there is supposedly a fix for this in grub CVS, but it's related to
a complete rewrite of the Linux booting support.  I'm planning to resync soon
and will try to get a test package once I've done so
Comment 4 Need Real Name 2002-10-01 03:31:40 EDT
Hoping that new version 8.0 might include the fix you mentioned, I took the 
step of downloading the ISOs today and made installation. No improvement; same 
problem, same symptoms.

It's now almost a month since this Error 28 situation has been known to you. 
What's it going to take to get it fixed, an act of Congress? If finding time to 
deal with it is something entirely beyond you, for God's sake assign it to 
someone else. 

John Lowell
Comment 5 Jeremy Katz 2002-10-01 17:56:35 EDT
The initial report wasn't until very late in our development cycle. 
Unfortunately, the fix for this upstream has been a complete rewrite of the
Linux loading code and so it was far too risky to include that late, especially
as there wasn't a new upstream release of grub available and it's not just one
simple change to backport.

My current work-in-progress package for resyncing with upstream is available at
http://people.redhat.com/~katzj/grub/grub-0.93-0.20021001.i386.rpm if you'd like
to try it out. If you install the package and then run '/sbin/grub-install
/dev/hda' (or wherever you chose to install the boot loader, you should be able
to see if it works
Comment 6 Toralf 2002-10-16 12:00:07 EDT
Worksforme! Only one minor problem: I don't get a background (splash) image, but
perhaps the support isn't enabled in your build?
Comment 7 Jeremy Katz 2002-12-29 01:33:36 EST
GRUB 0.93 has now been officially released and the graphics patch has been
updated to work with the newer release.  Should be in rawhide soon-ish.
Comment 8 Jeremy Katz 2002-12-29 01:34:06 EST
*** Bug 74686 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2002-12-29 01:36:25 EST
*** Bug 78436 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2006-08-04 16:13:57 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.