Bug 74686 - grub doesn't work on Sun LX50
Summary: grub doesn't work on Sun LX50
Status: CLOSED DUPLICATE of bug 73586
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-30 19:28 UTC by Chris Ricker
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-09-30 19:28:13 UTC
This is a Sun LX50 (Sun's Intel-based Linux box; ServerWorks chipset):

[root@station200 root]# lspci
00:00.0 Host bridge: ServerWorks CNB20HE Host Bridge (rev 23)
00:00.1 Host bridge: ServerWorks CNB20HE Host Bridge (rev 01)
00:00.2 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
00:00.3 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
00:03.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 0d)
00:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 0d)
00:0c.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
00:0f.0 ISA bridge: ServerWorks CSB5 South Bridge (rev 92)
00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 92)
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 USB Controller (rev 05)
00:0f.3 Host bridge: ServerWorks: Unknown device 0230
01:07.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
01:07.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
[root@station200 root]# 

lilo works as a boot loader.  grub works if the ethernet cable is unplugged
until after the kernel is loaded (the machine has non-disableable PXE crud built
into the BIOS which apparently gets loaded if link is detected).  grub fails if
the ethernet cable is plugged in during boot up.  The failure is an out of
memory error while attempting to load the kernel....

Comment 1 Jeremy Katz 2002-10-01 22:11:32 UTC
Can you try the grub 0.93 cvs snap package at
http://people.redhat.com/~katzj/grub/grub-0.93-0.20021001.i386.rpm?  It doesn't
have splash screen support, but this should be fixed (large chunks of code have
been rewritten and are supposed to have a fix for the problem)

Comment 2 Chris Ricker 2002-10-01 23:06:19 UTC
Yep, that fixes it....

Comment 3 Jeremy Katz 2002-12-29 06:34:04 UTC

*** This bug has been marked as a duplicate of 73586 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:49:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.