Bug 735872 - Fedora desktop does not have file sharing options installed by default
Summary: Fedora desktop does not have file sharing options installed by default
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xfconf
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 21:17 UTC by Timothy Miller
Modified: 2011-09-13 22:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 22:24:56 UTC


Attachments (Terms of Use)

Description Timothy Miller 2011-09-05 21:17:05 UTC
Description of problem:
Most modern OS's (Windows, MacOS, Ubuntu) provide really simple ways to share files via various protocols (SMB, NFS, etc.).  For instance on Windows, I can right-click and select "Sharing".  On MacOS X, there is an option in the user preferences.  

I'm using Xfce on Fedora 15, so perhaps there's a hidden option, but as far as I can tell, Fedora desktop simply lacks any easy means to set up file sharing.  After more than an hour of fruitless googling and rude remarks from people in the #fedora IRC channel, I finally discovered the existence of "samba-config-samba".  I'm usually good at googling stuff, but I guess I just didn't have enough of a clue as to what to look for, because that never came up.  Any more novice user will be completely baffled.

[It also turns out that system-config-samba doesn't automatically configure SELinux, and also provides no warning about it.  I have filed a separate bug on that.]

Note that I could have configured Samba manually.  It just seems to me that this is a common-enough thing that there should be a built-in GUI tool for it.  Also, one of my concerns with poking around under the hood like that is that I might break something if Fedora does things in an unexpected way.  If I can find a GUI tool to set something up, it's more likely that it'll get done "right".  (Or so one would hope to assume.)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bill Nottingham 2011-09-06 03:16:38 UTC
GNOME has simple file sharing built in (see the gnome-user-share package). system-config-samba/system-config-nfs are more for setting up a file server.

XFCE may not have something built in. Assigning to a main XFCE package for discussion there.

Comment 2 Timothy Miller 2011-09-06 13:22:05 UTC
Good point about XFCE.  Note, however, that I originally installed Fedora with the defaults, so I got GNOME 3, but it didn't like my graphics card, so I had to manually install XFCE.  Maybe in this case, the problem is that XFCE didn't pick up all of GNOME's tools.

Comment 3 Kevin Fenzi 2011-09-06 14:53:21 UTC
What OS are the other machine(s) you are sharing with?

Your best bet for Xfce is a package called 'gigolo' (yes, it's a horrible name). It allows you to setup ssh/ftp/obex/webdav connections. If all the machines are linux or have ssh, the ssh option should work great. 

For samba/smb, Thunar (the Xfce file manager) can access shares provided that gvfs-smb is installed. (However, there's a Thunar bug preventing this from working that is fixed in an update: see bug 712469 ).

system-config-samba is in the group for setting up a windows fileshare sever. 

So, do any of those meet your needs? I'm not sure what the resolution here should be... more docs? Xfce does not possess a simple 'share this' in Thunar, although a request could be made to upstream to add such.

Comment 4 Timothy Miller 2011-09-12 17:32:38 UTC
I'm not able to provide a good judgement as to what would be best.  You could provide a centralized tool (with a name people will understand) to select directories to share (like MacOS), or you could provide "share this" from the context menu (like Windows).  I think "both" is probably the best answer for most of these things, in order to fulfill most users' expectations.  

I was confused because I just expected there to be file sharing installed by default in an obvious place.  This is something many people have come to expect from modern desktop platforms.  Of course, I'm not really sure, objectively, how "basic" it is.  Most PC users barely know how to send an email.  In any case, even Ubuntu makes it dead easy (http://www.simplehelp.net/2007/05/19/how-to-share-files-and-folders-in-ubuntu/), although not everyone want to use Ubuntu.

Comment 5 Kevin Fenzi 2011-09-12 23:52:08 UTC
Well, this is more a discussion for upstream Xfce than me (I package Xfce for Fedora, but they would be the ones to decide to implement some easy sharing application). 

Would you care to take this discussion the Xfce users or developers list or would you like me to do so?
http://www.xfce.org/community/

Comment 6 Timothy Miller 2011-09-13 14:45:05 UTC
Maybe this is going to sound like a copout, but you know Xfce way better than I do.  If you're too busy, let me know, and I'll handle it.  Otherwise, you're going to have a lot more relevant knowledge and weight with the community.

Thanks!

Comment 7 Kevin Fenzi 2011-09-13 22:24:56 UTC
I'd be happy to open a thread on the upstream devel list about this. ;) 

I'm going to go ahead and close this now unless you can think of anything further we can do here. 

Thanks for your input!


Note You need to log in before you can comment on or make changes to this bug.