Bug 735970 - openssh-5.9p1 is available
openssh-5.9p1 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 737084 737295 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-06 06:36 EDT by Upstream Release Monitoring
Modified: 2011-09-21 08:42 EDT (History)
12 users (show)

See Also:
Fixed In Version: openssh-5.9p1-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-21 08:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2011-09-06 06:36:02 EDT
Latest upstream release: 5.9p1
Current version in Fedora Rawhide: 5.8p2
URL: http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Jan F. Chadima 2011-09-06 15:45:52 EDT
I have prepared package, but the upstream tarball is still buggy according to djm. The repaired package is announced for tomorrow.
Comment 2 Orion Poplawski 2011-09-08 13:03:05 EDT
5.9p1-1.fc17 doesn't work for me.  I appear to connect but never get a shell.  Debug shows:

debug1: Entering interactive session.
debug1: channel 0: free: client-session, nchannels 1
debug3: channel 0: status: The following connections are open:
  #0 client-session (t3 r-1 i0/0 o0/0 fd 4/5 cfd -1)

Then after a long timeout:

debug3: channel 0: close_fds r 4 w 5 e 6 c -1
Read from remote host vmrawhide: Connection reset by peer

Downgrading to 5.8p2-21.fc17 works.
Comment 3 Jan F. Chadima 2011-09-09 02:21:11 EDT
(In reply to comment #2)
> 5.9p1-1.fc17 doesn't work for me.  I appear to connect but never get a shell. 
> Debug shows:
> 
> debug1: Entering interactive session.
> debug1: channel 0: free: client-session, nchannels 1
> debug3: channel 0: status: The following connections are open:
>   #0 client-session (t3 r-1 i0/0 o0/0 fd 4/5 cfd -1)

have you fully upgdaded rawhide?
Comment 4 Orion Poplawski 2011-09-09 13:05:05 EDT
Yes.  Using --skip-broken to avoid packages with dependency issues.

Actually the hang occurs here on the client:

debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.


On the server:

ep  9 10:52:21 vmrawhide sshd[13048]: debug2: userauth_pubkey: authenticated 1 pkalg ssh-rsa [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_do_pam_account entering [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_request_send entering: type 51 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_request_receive_expect entering: type 52 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_request_receive entering [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_do_pam_account returning 1 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_send_keystate: Sending new keys: 0x7f4c758bc0f0 0x7f4c758bbdd0 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_newkeys_to_blob: converting 0x7f4c758bc0f0 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_newkeys_to_blob: converting 0x7f4c758bbdd0 [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_send_keystate: New keys have been sent [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_send_keystate: Sending compression state [preauth]
Sep  9 10:52:21 vmrawhide sshd[13048]: debug3: mm_request_send entering: type 25 [preauth]
Comment 5 Jan F. Chadima 2011-09-09 16:27:52 EDT
*** Bug 737084 has been marked as a duplicate of this bug. ***
Comment 6 Michal Jaegermann 2011-09-10 14:02:12 EDT
Currently the latest openssh-5.9p1-3 does not allow to connect too.
Comment 7 Jim Meyering 2011-09-10 16:00:28 EDT
*** Bug 737295 has been marked as a duplicate of this bug. ***
Comment 8 Jim Meyering 2011-09-10 16:22:42 EDT
With the tip in comment #2, I ran these commands from an empty directory:

    koji download-build --arch x86_64 openssh-5.8p2-21.fc17
    yum downgrade *.rpm

and am now back in business.
Comment 9 Jan F. Chadima 2011-09-12 02:35:53 EDT
temporarily solved in openssh-5.9p1-5
Comment 10 Jim Meyering 2011-09-12 03:59:11 EDT
Thanks, Jan.
However, at least for me, the problem remains.
Symptoms unchanged after upgrade and reboot, so I've downgraded again.
Comment 11 Jan F. Chadima 2011-09-12 04:28:38 EDT
(In reply to comment #10)
> Thanks, Jan.
> However, at least for me, the problem remains.
> Symptoms unchanged after upgrade and reboot, so I've downgraded again.
have you tested REALLY openssh-5.9p1-5 ?
Comment 12 Jim Meyering 2011-09-12 04:36:46 EDT
Oh!  You're right.  I tested p1-3.  Sorry about that.
I've just downloaded the latest from koji,

    koji download-build --arch x86_64 openssh-5.9p1-5.fc17

installed its rpms, restarted sshd, and *it* does work.

Thank you!

Note You need to log in before you can comment on or make changes to this bug.