Bug 736071 - kvm modules are not loaded in fedora16 - nested virtualisation approach
kvm modules are not loaded in fedora16 - nested virtualisation approach
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 736072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-06 11:11 EDT by melchiaros
Modified: 2012-05-04 09:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 09:15:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the fedora16 guest - no kvm modules after newstart (414.36 KB, image/png)
2011-09-06 11:17 EDT, melchiaros
no flags Details
message and libvirt logs (816.51 KB, application/x-gzip)
2011-09-06 11:19 EDT, melchiaros
no flags Details
the loags from the fedora16 guest - eith libvirt (90.21 KB, application/x-gzip)
2011-09-06 11:36 EDT, melchiaros
no flags Details
there was also a network error in the fedora16 guest (400.64 KB, image/jpeg)
2011-09-06 11:40 EDT, melchiaros
no flags Details

  None (edit)
Description melchiaros 2011-09-06 11:11:09 EDT
Description of problem:
I´ve tried to do nested virtulisation with KVM from a fedora 15 host and a fedora16 guest with a openSUSE12.1 MS5 subguest.

The problem is that the fedora16 guest does not load kvm modules.

I first attach the files and logs for the fedora 15 host and later(when I get them) for the fedora16 guest.


Version-Release number of selected component (if applicable):

from the fedora15 host:

[user@localhost ~]$ rpm -qa | grep virt-manager
virt-manager-0.8.7-4.fc15.noarch
[user@localhost ~]$ rpm -qa | grep kvm
qemu-kvm-0.14.0-7.fc15.x86_64
[user@localhost ~]$ rpm -qa | grep qemu
gpxe-roms-qemu-1.0.1-4.fc15.noarch
qemu-system-x86-0.14.0-7.fc15.x86_64
qemu-kvm-0.14.0-7.fc15.x86_64
qemu-common-0.14.0-7.fc15.x86_64
qemu-img-0.14.0-7.fc15.x86_64
[user@localhost ~]$ rpm -qa | kernel
bash: kernel: command not found...
[user@localhost ~]$ rpm -qa | grep kernel
arm-gp2x-linux-kernel-headers-2.6.12.0-5.fc15.noarch
abrt-addon-kerneloops-2.0.3-1.fc15.x86_64
kernel-debug-2.6.40.3-0.fc15.x86_64
kernel-2.6.38.6-26.rc1.fc15.x86_64
kernel-devel-2.6.40.3-0.fc15.x86_64
kernel-headers-2.6.40.3-0.fc15.x86_64
kernel-2.6.40.3-0.fc15.x86_64




How reproducible:


Steps to Reproduce:
1.use fedora 15 as host 
2.install the virtualisation meta package
3.create fedora16 guest with virt-manager
4.install the virtualisation meta package in the fedora 16 guest
5. try to install a guest(whatever- I´ve used openSUSE12.1 MS5)in the fedora16 guest(after a newstart - you know) with virt-manager and kvm
6. see the message from virt-manager that the kvm modules are not loaded.
  
Actual results:
not working nested virtualisation with kvm

Expected results:
nested virtualisation should work with kvm

Additional info:

give me some time to complete this report here.
Comment 1 melchiaros 2011-09-06 11:16:11 EDT
Have forgotten to set the severity to medium.
Comment 2 melchiaros 2011-09-06 11:17:44 EDT
Created attachment 521687 [details]
the fedora16 guest - no kvm modules after newstart
Comment 3 melchiaros 2011-09-06 11:19:50 EDT
Created attachment 521688 [details]
message and libvirt logs
Comment 4 melchiaros 2011-09-06 11:20:57 EDT
the logs above are from the fedora 15 host.
Comment 5 melchiaros 2011-09-06 11:36:36 EDT
Created attachment 521693 [details]
the loags from the fedora16 guest - eith libvirt
Comment 6 melchiaros 2011-09-06 11:40:04 EDT
Created attachment 521697 [details]
there was also a network error in the fedora16 guest
Comment 7 melchiaros 2011-09-06 11:41:25 EDT
That it is from my side.
Comment 8 Andy Lawrence 2011-09-06 17:20:46 EDT
*** Bug 736072 has been marked as a duplicate of this bug. ***
Comment 9 Cole Robinson 2012-05-04 09:15:01 EDT
If installing the guest with virt-manager, you need to go to VM->CPU->Copy host cpu  to ensure that all the host CPU flags are passed to the guest.

Either way, the KVM package was merged with the qemu package, so any future issues should be filed against the 'qemu' component, or in this case 'virt-manager' or 'libvirt.

Note You need to log in before you can comment on or make changes to this bug.