Bug 736239 - [RHEL5.7/6.1]Can't get boot message by the tool netconsole
Summary: [RHEL5.7/6.1]Can't get boot message by the tool netconsole
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
: 736241 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 06:40 UTC by ronglux
Modified: 2011-09-23 14:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-23 14:15:01 UTC


Attachments (Terms of Use)

Description ronglux 2011-09-07 06:40:23 UTC
Description of problem:
I used to get boot message by the tool netconsole on SLES(D) platform successful,I tried to get boot message in RHEL 6.1/5.7 failed now ,but it can get the panic info by the netconsole.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 6.1
Red Hat Enterprise Linux Server release 5.7

How reproducible:
always

Steps to Reproduce:
1.setup the netconsole env on the server
2.reboot the machine
3.use the command "netcat -l -u -p xxxx" from on the client
 
Actual results:
Can't capture the boot message by netconsole but the panic info can be captured.


Expected results:
Also capture the panic and boot message like SLES(D) platform.

Additional info:
My network card support netpoll.
UDP pakets and ethernet devices are supported.

Comment 1 Jiri Popelka 2011-09-07 08:55:46 UTC
Definitely not a net-tools problem. From the description I'm not sure whether the problem is in server (kernel) or client (netcat). Let's start with netcat.

Comment 2 Petr Šabata 2011-09-07 09:46:46 UTC
*** Bug 736241 has been marked as a duplicate of this bug. ***

Comment 3 Petr Šabata 2011-09-07 09:51:29 UTC
As far as I know, there's no RHEL package providing the 'netcat' command.

It's not possible to run 'nc' with both -l and -p switches.  Are you using
nmap's 'ncat'?

Comment 4 ronglux 2011-09-08 06:23:24 UTC
(In reply to comment #1)
> Definitely not a net-tools problem. From the description I'm not sure whether
> the problem is in server (kernel) or client (netcat). Let's start with netcat.

I tried to compile many types of kernel in server but it still can't get the boot message.

In client(RHEL) i can get a small number of boot message from the server(SLED platform).  

[root@test ~]# netcat -l -u -p 33333|tee -i netlog
[   13.004919] device-mapper: uevent: version 1.0.3
[   13.344368] loop: module loaded
[   15.846877] fuse init (API version 7.13)
[   16.195994] type=1505 audit(1315419142.000:2): operation="profile_load" pid=1228 name=/bin/ping
[   16.248971] type=1505 audit(1315419142.052:3): operation="profile_load" pid=1245 name=/sbin/klogd
[   16.294348] type=1505 audit(1315419142.096:4): operation="profile_load" pid=1273 name=/sbin/syslog-ng
[   16.336467] type=1505 audit(1315419142.140:5): operation="profile_load" pid=1276 name=/sbin/syslogd
[   16.443685] type=1505 audit(1315419142.248:6): operation="profile_load" pid=1285 name=/usr/sbin/avahi-daemon
[   16.565766] type=1505 audit(1315419142.372:7): operation="profile_load" pid=1295 name=/usr/sbin/identd
[   16.638547] type=1505 audit(1315419142.444:8): operation="profile_load" pid=1304 name=/usr/sbin/mdnsd
[   16.739974] type=1505 audit(1315419142.544:9): operation="profile_load" pid=1318 name=/usr/sbin/nscd
[   16.797978] type=1505 audit(1315419142.604:10): operation="profile_load" pid=1319 name=/usr/sbin/ntpd
[   16.836358] type=1505 audit(1315419142.640:11): operation="profile_load" pid=1320 name=/usr/sbin/traceroute
[   17.541346] microcode: CPU0 sig=0x306a2, pf=0x10, revision=0x8
[   17.622104] microcode: CPU1 sig=0x306a2, pf=0x10, revision=0x8
[   17.625567] microcode: CPU2 sig=0x306a2, pf=0x10, revision=0x8
[   17.628943] microcode: CPU3 sig=0x306a2, pf=0x10, revision=0x8
[   17.632075] microcode: CPU4 sig=0x306a2, pf=0x10, revision=0x8
[   17.635282] microcode: CPU5 sig=0x306a2, pf=0x10, revision=0x8
[   17.638584] microcode: CPU6 sig=0x306a2, pf=0x10, revision=0x8
[   17.641866] microcode: CPU7 sig=0x306a2, pf=0x10, revision=0x8
[   17.645199] Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[   18.626079] NET: Registered protocol family 10
[   19.605404] BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
[root@test ~]# ^C
[root@test ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.1 (Santiago)
Kernel \r on an \m

[root@test ~]# uname -r
2.6.32-193.el6.x86_64

Comment 5 ronglux 2011-09-08 06:26:59 UTC
(In reply to comment #3)
> As far as I know, there's no RHEL package providing the 'netcat' command.
> It's not possible to run 'nc' with both -l and -p switches.  Are you using
> nmap's 'ncat'?

in fact there is no netcat package providing.
so i downloaded a tarball(netcat-0.7.1.tar.bz2) and installed it.

Comment 6 Petr Šabata 2011-09-08 06:45:28 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > As far as I know, there's no RHEL package providing the 'netcat' command.
> > It's not possible to run 'nc' with both -l and -p switches.  Are you using
> > nmap's 'ncat'?
> 
> in fact there is no netcat package providing.
> so i downloaded a tarball(netcat-0.7.1.tar.bz2) and installed it.

I can't really help you with software we don't ship.  I also doubt a netcat client is dropping some messages and some not.  I'd check the network.

Anyhow, since I can't do anything here, moving to kernel.  I guess they won't have anything to add, though.

Comment 7 Prarit Bhargava 2011-09-23 14:15:01 UTC
We don't support software we don't ship.  Closed as NOTABUG.

P.


Note You need to log in before you can comment on or make changes to this bug.