Bug 736375 - [winbindd] Too low debug level when attempting to register an already registered idmap module
[winbindd] Too low debug level when attempting to register an already registe...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: 5.8
Assigned To: Guenther Deschner
Martin Cermak
:
Depends On:
Blocks: 668957 739186
  Show dependency treegraph
 
Reported: 2011-09-07 10:11 EDT by Julio Entrena Perez
Modified: 2012-02-21 00:44 EST (History)
7 users (show)

See Also:
Fixed In Version: samba3x-3.5.4-0.89.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 739186 (view as bug list)
Environment:
Last Closed: 2012-02-21 00:44:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Raising debug level to avoid high verbosity. (1.32 KB, patch)
2011-09-09 12:38 EDT, Julio Entrena Perez
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 55450 None None None Never

  None (edit)
Description Julio Entrena Perez 2011-09-07 10:11:45 EDT
> Description of problem:
Winbindd creates excessive debug output 

> Version-Release number of selected component (if applicable):
samba3x-winbind-3.5.4-0.83.el5_7.2

> How reproducible:
Always.

> Steps to Reproduce:
1. Configure a Samba server as member of an Active Directory.
2. Configure one or more shares.
3. Browse a share from another machine.

> Actual results:
The following entries are logged with debug level 0:

Sep  2 08:30:57 samba01 winbindd[3822]: [2011/09/02 08:30:57.282848,  0]
winbindd/idmap.c:201(smb_register_idmap_alloc)
Sep  2 08:30:57 samba01 winbindd[3822]:   idmap_alloc module ldap already
registered!
Sep  2 08:30:57 samba01 winbindd[3822]: [2011/09/02 08:30:57.283017,  0]
winbindd/idmap.c:201(smb_register_idmap_alloc)
Sep  2 08:30:57 samba01 winbindd[3822]:   idmap_alloc module tdb already
registered!
Sep  2 08:30:57 samba01 winbindd[3822]: [2011/09/02 08:30:57.283049,  0]
winbindd/idmap.c:149(smb_register_idmap)
Sep  2 08:30:57 samba01 winbindd[3822]:   Idmap module passdb already
registered!
Sep  2 08:30:57 samba01 winbindd[3822]: [2011/09/02 08:30:57.283081,  0]
winbindd/idmap.c:149(smb_register_idmap)
Sep  2 08:30:57 samba01 winbindd[3822]:   Idmap module nss already registered!

Since debug level is 0, these messages can not be filtered lowering the "log
level" parameter at smb.conf.

> Expected results:
These messages should have a higher debug level so they could be filtered by
the smb.conf "log level" parameter.

> Additional info:
These messages are harmless and expected due to the lazy initialization for
idmap modules.

http://samba.2283325.n4.nabble.com/Module-already-registered-td3002095.html

Duplicate shares (the same directory being accessible through more than one
share) are known to cause this too. This is not the case there though.
Comment 1 Julio Entrena Perez 2011-09-09 12:38:45 EDT
Created attachment 522367 [details]
Raising debug level to avoid high verbosity.

Attaching a proposed patch.
Using debug level 5 as this is the one used when the registration is successful.
Comment 8 errata-xmlrpc 2012-02-21 00:44:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0156.html

Note You need to log in before you can comment on or make changes to this bug.