Bug 736422 - VDSM - should be able to recover from malformed message from rhev-agent
Summary: VDSM - should be able to recover from malformed message from rhev-agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Jakub Libosvar
URL:
Whiteboard:
: 738355 (view as bug list)
Depends On:
Blocks: 736426
TreeView+ depends on / blocked
 
Reported: 2011-09-07 16:33 UTC by Barak
Modified: 2011-12-06 07:28 UTC (History)
6 users (show)

Fixed In Version: vdsm-4.9-101
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:28:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Barak 2011-09-07 16:33:47 UTC
Description of problem:

Using the current VDSM <-> rhev-agent protocol, VDSM can't recover from a malformed message, and the channel between the VDSM to the rhev-agent becomes useless.

This protocol's origin is in the old hypercall device (not upstream) on rhel 5.X.

On RHEL 6 we moved to vioserial device.

On one of the vioserial discussions, it was brought up that the vioserial does not guarantee that the message will reach it's destiny intact (this was especially emphasized in the last round of discussions regarding s3/s4 support).



In order to be able to recover the protocol must be altered to identify the malformed message and drop it.

Since the VDSM <-> rhev-agent API is stateless dropping a single (malformed) message does not break anything.

Comment 8 Dan Kenigsberg 2011-09-15 11:00:57 UTC
*** Bug 738355 has been marked as a duplicate of this bug. ***

Comment 10 Jakub Libosvar 2011-09-26 08:31:29 UTC
Verified between agent rhev-agent-2.3.14-1.el6 and vdsm-4.9-104.el6.x86_64

Comment 11 errata-xmlrpc 2011-12-06 07:28:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.