Bug 738355 - [vdsm] [guestIF] UnboundLocalError: local variable 'line' referenced before assignment
Summary: [vdsm] [guestIF] UnboundLocalError: local variable 'line' referenced before ...
Keywords:
Status: CLOSED DUPLICATE of bug 736422
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: David Naori
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 15:34 UTC by David Naori
Modified: 2011-09-15 11:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 11:00:56 UTC


Attachments (Terms of Use)
vdsm log (323.06 KB, application/x-xz)
2011-09-14 15:34 UTC, David Naori
no flags Details

Description David Naori 2011-09-14 15:34:17 UTC
Created attachment 523183 [details]
vdsm log

Description of problem:

Thread-825::ERROR::2011-09-14 17:52:02,018::guestIF::268::vm.Vm::(run) vmId=`ff1ef43c-bf3d-4231-8545-26731306a048`::Unexpected exception: Traceback (most recent call last):
  File "/usr/share/vdsm/guestIF.py", line 265, in run
    self.log.exception("Run exception: %s", line)
UnboundLocalError: local variable 'line' referenced before assignment

            while not self._stopped:
                try:
                    line = self._readLine()
                    # line is always None after stop() is called and the
                    # socket is closed.
                    if line:
                        (message, args) = self._parseLine(line)
                        self._agentTimestamp = time.time()
                        self._handleMessage(message, args)
                except:
                    self.log.exception("Run exception: %s", line)


should set line to None before the read

Version-Release number of selected component (if applicable):
vdsm-4.9-98.el6.x86_64

How reproducible:
happened in migration destenation

Actual results:


Expected results:


Additional info:

Comment 2 Dan Kenigsberg 2011-09-14 18:28:42 UTC
BTW David, this bug was introduced in vdsm-4.9-99-7-ga5f8785 (vdsm-4.9-100).

Any word on how to reproduce it, and the functional effect?

Thanks for the suggested fix, I've posted it under your name at

http://gerrit.usersys.redhat.com/936

Comment 3 David Naori 2011-09-14 21:08:40 UTC
(In reply to comment #2)
> BTW David, this bug was introduced in vdsm-4.9-99-7-ga5f8785 (vdsm-4.9-100).
> 
> Any word on how to reproduce it, and the functional effect?
> 
> Thanks for the suggested fix, I've posted it under your name at
> 
> http://gerrit.usersys.redhat.com/936

i don't know if there is any functional effects, and i don't know exactly how to reproduce it, i just saw it in the log after some concurrent migrations -
since the fix is simple i didn't find it significant to investigate the cause.

i can try to reproduce it anytime if needed.

Comment 5 Dan Kenigsberg 2011-09-15 11:00:56 UTC
If not fixed, vdsm may stop waiting for guest messages after migration (which is bad). This is a failure of the first implementation of the fix for bug 736422, and should be verified as a part of it. No need to chase more flags.

*** This bug has been marked as a duplicate of bug 736422 ***


Note You need to log in before you can comment on or make changes to this bug.