Bug 736444 - IPv6: ip -6 route prints routing cache
Summary: IPv6: ip -6 route prints routing cache
Status: CLOSED DUPLICATE of bug 841967
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 17:21 UTC by Pavel Šimerda (pavlix)
Modified: 2013-04-19 17:37 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-29 09:45:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Šimerda (pavlix) 2011-09-07 17:21:13 UTC
Description of problem:

Command ip -6 route without other parameters prints routing cache records.

Version-Release number of selected component (if applicable):

iproute-2.6.38.1-4.fc15.x86_64
kernel-2.6.40.3-0.fc15.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. sudo ip -6 route flush cache
2. ip -6 route | grep 2a02:38::1001 -A 1
3. ping6 2a02:38::1001
4. ip -6 route | grep 2a02:38::1001 -A 1
  
Actual results:

Empty result after (2), cached record for 2a02:38::1001 after (4)


Expected results:

Empty result also after (4), as in IPv4.


Additional info:

This bug causes problems to anyone who wants to debug IPv6 configuration with standard Linux tools.

Comment 1 Pavel Šimerda (pavlix) 2011-09-09 00:47:58 UTC
Reproduced with kernel-2.6.40.4-5.fc15.x86_64

Comment 2 Petr Šabata 2011-09-14 15:06:52 UTC
iproute[2] doesn't manipulate the data; the tables are printed as they are stored by the kernel.  I'd say this is a feature.

Assigning to kernel for some insight.

Comment 3 Chuck Ebbert 2011-09-16 09:01:44 UTC
Did this just start happening with kernel 2.6.40? (In other words, did 2.6.38 work as expected?) If so, we may need to update iproute in F15 to version 2.6.39. You could try installing the one from F16 and see if that works.

Comment 4 Neil Horman 2013-04-19 17:37:59 UTC

*** This bug has been marked as a duplicate of bug 841967 ***


Note You need to log in before you can comment on or make changes to this bug.