Bug 841967 - "ip", "netstat" and "route" commands always show IPv6 cached as well as configured routes
"ip", "netstat" and "route" commands always show IPv6 cached as well as confi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 736444 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 13:31 EDT by Phil Mayers
Modified: 2013-04-19 13:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-19 13:37:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Mayers 2012-07-20 13:31:41 EDT
Description of problem:

This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=736444

However, I couldn't figure out how to re-open that bug, and it applies to Fedora 15 anyway.

Version-Release number of selected component (if applicable):

kernel is 3.4.0-1.fc17.i686.PAE
net-tools-1.60-134.20120127git.fc17.i686
iproute-3.3.0-2.fc17.i686

How reproducible:

Always, apparently on any Fedora 17 or 16 machine (15 as well?)

Steps to Reproduce:
1. Configure IPv6 and generate some IPv6 traffic
2. View the IPv6 routing table with any of the following

  ip -6 route
  route -n -A inet6
  netstat -A inet6 -rn

3. Look at the output - see that it includes IPv6 caches entries
  
Actual results:

Routing table shows cached as well as configured entries in all tools, so it's impossible to see which entries are configured, and which are cached and will expire / can be ignored.

Expected results:

Cached routes should only be visible if asked for with:

 ip -6 route show table cache

...as is the case for IPv4, or older kernels.

Additional info:

This is a behaviour change. I believe it worked as expected in Fedora 14, but can't be sure.

It works as expected in RHEL6 and earlier.
Comment 1 Justin M. Forbes 2012-09-07 10:41:50 EDT
Kernel 3.4.0 is considerably outdated, does this still happen with 3.5.3?
Comment 2 Phil Mayers 2012-09-07 10:56:44 EDT
It happens with kernel 3.4.7 under F16. 3.4.7 was tagged 29 Jul 2012, and the RPM built 30 Jul 2012, and the gitweb history for the stable kernel reports no obvious related changes to the net/ipv6 tree since then.

Do you have a specific reason to assume it *doesn't* happen with 3.5.3?

We only have a couple of F17 machines and can't take a reboot to get the new kernel in at the moment. It might be easier to try and reproduce it yourself locally if you have a 3.5.3 machine.

Otherwise, we'll schedule a reboot next week and look then.
Comment 3 Neil Horman 2013-04-19 13:37:10 EDT
ip, route and netstat have shown cached routes for quite some time now.  If you just want to see configured routes you need to filter by proto, i.e.:

ip -6 route list proto statc
ip -6 route list proto kernel
ip -6 route list proto <tableid>

etc.
Comment 4 Neil Horman 2013-04-19 13:37:59 EDT
*** Bug 736444 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.