Bug 73647 - rhnlib hangs after "Connection reset by peer"
rhnlib hangs after "Connection reset by peer"
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhnlib (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 14:56 EDT by Scott Lamb
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Lamb 2002-09-07 14:56:32 EDT
Description of Problem:

When updating packages, I got a "Connection reset by peer" error. (These are
kind of a fact of life for me at the moment - I think my little D-Link masqing
router box has problems.) Instead of retrying, up2date gave me a stack trace and
hung.

Version-Release number of selected component (if applicable):

rhnlib-1.0-1
up2date-2.9.68-1

How Reproducible:

By forcing a "Connection reset by peer". The only way I can think to do this at
the moment is by running through a masqing router and flushing its connection
table midway through. There may be a better way...

Actual Results:

up2date gives a stack trace and hangs

Expected Results:

up2date retries the connection

Additional Information:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1414, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 260, in getPackage
    buffer = rpcServer.doCall(rpmSource.psc.packageSource.getPackage, pkg,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 215, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 685, in getPackage
    fd = self.s.getPackage(channel, filename)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 118, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 602, in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 537, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 553, in _send_request
    self.putrequest(method, url)
  File "/usr/lib/python2.2/httplib.py", line 453, in putrequest
    self.send(str)
  File "/usr/lib/python2.2/httplib.py", line 407, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 185, in write
    sent = self._connection.send(data)
SSL.SysCallError: (104, 'Connection reset by peer')
Comment 1 Mihai Ibanescu 2002-09-08 21:24:54 EDT
I'll have a look. Error conditions have not been thoroughly tested with rhnlib,
mostly because it's difficult to figure them out in the first place :-)
Comment 2 Arenas Belon, Carlo Marcelo 2003-04-13 18:11:13 EDT
a similar problem that affects rhn-applet has been reported on Red Hat Linux 9
as you can see from bug #88270
Comment 3 Mihai Ibanescu 2004-08-31 09:51:28 EDT
Still on my plate to catch all exceptions.
Comment 4 Bill Nottingham 2006-08-07 16:09:06 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 13:32:42 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.