Bug 736643 - [abrt] liveusb-creator-3.11.4-1.fc15: creator.py:451:handle_reply:UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
Summary: [abrt] liveusb-creator-3.11.4-1.fc15: creator.py:451:handle_reply:UnicodeEnco...
Keywords:
Status: CLOSED DUPLICATE of bug 590232
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e8594c43865dbd8c0eae277ff14...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 10:49 UTC by Misha Shnurapet
Modified: 2016-09-20 02:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-12 17:50:40 UTC


Attachments (Terms of Use)

Description Misha Shnurapet 2011-09-08 10:49:26 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python -tt /usr/sbin/liveusb-creator
comment:        
component:      liveusb-creator
executable:     /usr/sbin/liveusb-creator
kernel:         2.6.40-4.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        liveusb-creator-3.11.4-1.fc15
reason:         creator.py:451:handle_reply:UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
time:           Mon Aug  8 23:04:59 2011
uid:            0
username:       root

backtrace:
:creator.py:451:handle_reply:UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
:    reply_handler(*message.get_args_list(**get_args_opts))
:  File "/usr/lib/python2.7/site-packages/liveusb/creator.py", line 451, in handle_reply
:    'label': str(dev.Get(device, 'IdLabel')).replace(' ', '_'),
:UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
:
:Local variables in innermost frame:
:iface: 'usb'
:dev_obj: <ProxyObject wrapping <dbus._dbus.SystemBus (system) at 0xb71ef4dc> :1.31 /org/freedesktop/UDisks/devices/sdb1 at 0xb71f0fac>
:dbus: <module 'dbus' from '/usr/lib/python2.7/site-packages/dbus/__init__.pyc'>
:devices: dbus.Array([dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdd'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sda1'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sda2'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sda3'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sda4'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sde'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sda'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sr0'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdc'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdb1'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdf'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdg'), dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdb')], signature=dbus.Signature('o'))
:callback: <function add_devices at 0xb72b8374>
:dev: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at 0xb71ef4dc> :1.31 /org/freedesktop/UDisks/devices/sdb1 at 0xb71f0fac> implementing 'org.freedesktop.DBus.Properties' at 0xb71f61ac>
:device: dbus.ObjectPath('/org/freedesktop/UDisks/devices/sdb1')
:data: {'parent': None, 'fstype': '', 'fsversion': '', 'device': '/dev/sdc', 'is_optical': False, 'size': 0, 'udi': '/org/freedesktop/UDisks/devices/sdc', 'uuid': '', 'bootable': False, 'mount': [], 'label': ''}
:self: <liveusb.creator.LinuxLiveUSBCreator object at 0xb71f072c>

Comment 1 Luke Macken 2012-06-12 17:50:40 UTC

*** This bug has been marked as a duplicate of bug 590232 ***


Note You need to log in before you can comment on or make changes to this bug.