Bug 590232 - UnicodeEncodeError prevents starting of liveusb-creator
Summary: UnicodeEncodeError prevents starting of liveusb-creator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 567899 577602 600911 717356 736643 768940 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-08 08:56 UTC by Rudolf Kastl
Modified: 2016-09-20 02:40 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-26 00:33:21 UTC


Attachments (Terms of Use)

Description Rudolf Kastl 2010-05-08 08:56:13 UTC
Description of problem:
liveusb-creator 
(3135) KIconCache::Private::themeDirsChanged: Theme directory has been modified
Traceback (most recent call last):
  File "/usr/sbin/liveusb-creator", line 87, in <module>
    main()
  File "/usr/sbin/liveusb-creator", line 82, in main
    LiveUSBApp(opts, sys.argv)
  File "/usr/lib/python2.6/site-packages/liveusb/gui.py", line 55, in __init__
    self.mywindow = LiveUSBDialog(opts, args)
  File "/usr/lib/python2.6/site-packages/liveusb/gui.py", line 255, in __init__
    self.populate_devices()
  File "/usr/lib/python2.6/site-packages/liveusb/gui.py", line 284, in populate_devices
    self.live.detect_removable_drives()
  File "/usr/lib/python2.6/site-packages/liveusb/creator.py", line 435, in detect_removable_drives
    self._add_device(child, parent=dev)
  File "/usr/lib/python2.6/site-packages/liveusb/creator.py", line 463, in _add_device
    'label'   : str(dev.GetProperty('volume.label')).replace(' ', '_'),
UnicodeEncodeError: 'ascii' codec can't encode character u'\u065b' in position 4: ordinal not in range(128)


Version-Release number of selected component (if applicable):
liveusb-creator-3.9.1-1.fc13.noarch

How reproducible:
always

Comment 1 Bug Zapper 2010-07-30 11:34:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Christoph Wickert 2010-11-29 11:07:01 UTC
*** Bug 577602 has been marked as a duplicate of this bug. ***

Comment 3 Christoph Wickert 2010-11-29 11:07:07 UTC
*** Bug 567899 has been marked as a duplicate of this bug. ***

Comment 4 Christoph Wickert 2010-11-29 11:13:09 UTC
*** Bug 600911 has been marked as a duplicate of this bug. ***

Comment 5 Łukasz Mierzwa 2011-01-01 15:29:59 UTC
Package: liveusb-creator-3.9.2-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start "Fedora LiveUSB Creator" from start menu
2. abrt window pops up, "Fedora LiveUSB Creator" does not run 

Comment
-----
Probably locale related, my locale

LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

Comment 6 Thomas Ahle 2011-05-04 20:25:07 UTC
This happens on my system because my media is named "Nøglen" and so the mount point "/media/Nøglen" can't be encoded in ascii.

Bug 690451 is a duplicate of this.

Comment 7 Luke Macken 2012-06-12 17:48:08 UTC
*** Bug 717356 has been marked as a duplicate of this bug. ***

Comment 8 Luke Macken 2012-06-12 17:50:40 UTC
*** Bug 736643 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2012-06-12 17:55:09 UTC
liveusb-creator-3.11.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.7-1.fc16

Comment 10 Fedora Update System 2012-06-12 17:55:20 UTC
liveusb-creator-3.11.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.7-1.fc17

Comment 11 Fedora Update System 2012-06-12 17:55:30 UTC
liveusb-creator-3.11.7-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.7-1.el6

Comment 12 Fedora Update System 2012-06-12 17:55:40 UTC
liveusb-creator-3.11.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.7-1.fc15

Comment 13 Fedora Update System 2012-06-15 00:24:47 UTC
Package liveusb-creator-3.11.7-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liveusb-creator-3.11.7-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9384/liveusb-creator-3.11.7-1.fc17
then log in and leave karma (feedback).

Comment 14 Luke Macken 2012-06-22 16:19:23 UTC
*** Bug 768940 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2012-06-26 00:33:21 UTC
liveusb-creator-3.11.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2012-06-26 00:34:45 UTC
liveusb-creator-3.11.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-06-26 00:35:28 UTC
liveusb-creator-3.11.7-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-07-01 01:35:51 UTC
liveusb-creator-3.11.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.