Bug 736659 - FTBFS for koffice-2.3.3-9.fc16
Summary: FTBFS for koffice-2.3.3-9.fc16
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 735176 (view as bug list)
Depends On:
Blocks: FTBFS
TreeView+ depends on / blocked
 
Reported: 2011-09-08 11:28 UTC by Dan Horák
Modified: 2011-09-30 18:35 UTC (History)
7 users (show)

Fixed In Version: koffice-2.3.3-10.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 18:35:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes FTBFS (652 bytes, patch)
2011-09-08 14:10 UTC, Jaroslav Reznik
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-19703 None None None Never
KDE Software Compilation 275187 None None None Never

Description Dan Horák 2011-09-08 11:28:27 UTC
koffice-2.3.3-9.fc16 fails to build with recent QT (qt.s390x 1:4.8.0-0.9.beta1.fc16), the original build in primary arch was with qt.x86_64 1:4.7.3-7.fc16

Logs from s390 koji are at http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=456801 but it can be reproduced also on x86.

...
[  2%] Building CXX object plugins/chartshape/kdchart/kdchart/CMakeFiles/kdchart.dir/KDChartBackgroundAttributes.o
cd /builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu/plugins/chartshape/kdchart/kdchart && /usr/bin/c++   -DMAKE_KDCHART_LIB -D_BSD_SOURCE -DSHOULD_BUILD_RDF -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=21 -DKDCHART_BUILD_KDCHART_LIB -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -march=z9-109 -mtune=z10  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -O2 -DNDEBUG -DQT_NO_DEBUG -fPIC -I/builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu/plugins/chartshape/kdchart/kdchart -I/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart -I/builddir/build/BUILD/koffice-2.3.3 -I/builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu -I/builddir/build/BUILD/koffice-2.3.3/interfaces -I/builddir/build/BUILD/koffice-2.3.3/libs/kotext -I/builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu/libs/kotext -I/builddir/build/BUILD/koffice-2.3.3/libs/kotext/changetracker -I/builddir/build/BUILD/koffice-2.3.3/libs/kotext/styles -I/builddir/build/BUILD/koffice-2.3.3/libs/kotext/opendocument -I/builddir/build/BUILD/koffice-2.3.3/libs/flake -I/builddir/build/BUILD/koffice-2.3.3/libs/odf -I/builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu/libs/odf -I/builddir/build/BUILD/koffice-2.3.3/libs/koplugin -I/builddir/build/BUILD/koffice-2.3.3/libs/pigment -I/builddir/build/BUILD/koffice-2.3.3/libs/pigment/compositeops -I/builddir/build/BUILD/koffice-2.3.3/libs/pigment/resources -I/builddir/build/BUILD/koffice-2.3.3/libs/flake/commands -I/builddir/build/BUILD/koffice-2.3.3/libs/flake/tools -I/builddir/build/BUILD/koffice-2.3.3/s390x-redhat-linux-gnu/libs/flake -I/builddir/build/BUILD/koffice-2.3.3/libs/main -I/builddir/build/BUILD/koffice-2.3.3/libs/widgets -I/builddir/build/BUILD/koffice-2.3.3/libs/main/config -I/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/../include -I/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/../kdablibfakes/include -I/usr/include/kde4 -I/usr/include/kde4/KDE -I/usr/include/KDE -I/usr/include/phonon -I/usr/include/QtXmlPatterns -I/usr/include/QtXml -I/usr/include/QtWebKit -I/usr/include/QtUiTools -I/usr/include/QtTest -I/usr/include/QtSvg -I/usr/include/QtSql -I/usr/include/QtScriptTools -I/usr/include/QtScript -I/usr/include/QtOpenGL -I/usr/include/QtNetwork -I/usr/include/QtMultimedia -I/usr/include/QtHelp -I/usr/include/QtDesigner -I/usr/include/QtDeclarative -I/usr/include/QtDBus -I/usr/include/Qt3Support -I/usr/include/QtGui -I/usr/include/QtCore -I/usr/include/Qt -I/usr/lib64/qt4/mkspecs/default    -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o CMakeFiles/kdchart.dir/KDChartBackgroundAttributes.o -c /builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/KDChartBackgroundAttributes.cpp
/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/KDChartBackgroundAttributes.cpp: In function 'QDebug operator<<(QDebug, const KDChart::BackgroundAttributes&)':
/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/KDChartBackgroundAttributes.cpp:153:26: error: ambiguous overload for 'operator<<' in '(&(& operator<<(QDebug, const QBrush&)((*(const QBrush*)(& KDChart::BackgroundAttributes::brush() const()))).QDebug::operator<<(((const char*)"pixmapmode=")))->QDebug::operator<<(((int)(& ba)->KDChart::BackgroundAttributes::pixmapMode())))->QDebug::operator<<(((const char*)"pixmap=")) << KDChart::BackgroundAttributes::pixmap() const()'
/builddir/build/BUILD/koffice-2.3.3/plugins/chartshape/kdchart/kdchart/KDChartBackgroundAttributes.cpp:153:26: note: candidates are:
/usr/include/QtCore/qvariant.h:606:22: note: QDebug operator<<(QDebug, const QVariant&)
/usr/include/QtGui/qbrush.h:171:21: note: QDebug operator<<(QDebug, const QBrush&)

Comment 1 Jaroslav Reznik 2011-09-08 14:10:43 UTC
Created attachment 522128 [details]
Fixes FTBFS

Comment 2 Fedora Update System 2011-09-12 14:56:22 UTC
koffice-2.3.3-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/koffice-2.3.3-10.fc16

Comment 3 Fedora Update System 2011-09-13 00:09:57 UTC
Package koffice-2.3.3-10.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing koffice-2.3.3-10.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/koffice-2.3.3-10.fc16
then log in and leave karma (feedback).

Comment 4 Rex Dieter 2011-09-14 17:17:28 UTC
*** Bug 735176 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2011-09-30 18:35:24 UTC
koffice-2.3.3-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.