Bug 73687 - (evolution) Font Rendering Bug
(evolution) Font Rendering Bug
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtkhtml (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-08 17:14 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 05:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-09-08 17:14:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
This is a followup to Bug 70349.

Within certain installations of Valhalla, Limbo1, Limbo2, and Null, certain
fonts within gaim pre-0.59.1 and Evolution would fail to display.  Keep in mind
that this bug will not always occur.  It only appears within certain
installation instances of the above distribution versions, indicating that some
file or configuration may be missing or incorrect in that installation.

The gaim bug was somehow related to UTF-8 conversion problems, now fixed in
gaim-0.59.1-1.

This bug still occurs in the latest Evolution when you use the search filter on
an e-mail folder.  Normally when you use this feature and preview a message, the
preview pane will display that message with your search keyword highlighted. 
Instead it completely fails to display all instances of the search keyword.  You
can see this in this screenshot demonstrating a "gaim" keyword search.

http://www.mplug.org/archive/2002/evolution-search-blank-bug.php
Notice that each instance of the word "gaim" disappeared from the preview pane.
 It doesn't leave spaces where the missing characters should be.

The gaim and evolution font bug seemed to be connected in two ways:
1) Only occurs within certain installations, but not others on the same hardware.
2) If you highlight select the affected area including visible text before and
after the missing characters, middle-click in another window properly pastes the
text that was not rendered.

One workaround that reportedly fixed the earlier versions of gaim was setting
LANG=en_US instead of en_US.UTF-8.  (Note that this workaround didn't work for
me.)  Tested en_US in /etc/sysconfig/i18n and /etc/X11/gdm/locale.alias, but
this did not fix the font rendering misbehavior in evolution.

This misbehavior has been observed with an ATI and nVidia video card.  For more
details please read Bug 70349.
Comment 1 Warren Togami 2002-10-14 22:38:39 EDT
Still exists in Red Hat 8.0.  Very annoying.
Comment 2 Warren Togami 2003-01-03 05:39:54 EST
Seems to be fixed in Phoebe beta with Evolution 1.2.1.

Note You need to log in before you can comment on or make changes to this bug.