Bug 736943 - RFE: "Ctrl+Shift+u" & "enter email address" don't seem to work w/ibus-anthy
Summary: RFE: "Ctrl+Shift+u" & "enter email address" don't seem to work w/ibus-anthy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: rawhide
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 06:55 UTC by nomnex
Modified: 2013-09-23 00:39 UTC (History)
4 users (show)

Fixed In Version: ibus-anthy-1.5.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-18 13:01:39 UTC


Attachments (Terms of Use)
ibus+enter contact in sylpheed (178.63 KB, image/png)
2011-09-12 06:05 UTC, nomnex
no flags Details
1a - default address prefs (154.81 KB, image/png)
2011-10-03 08:45 UTC, nomnex
no flags Details
1b-Japanese anthy set, only a single letter can be entred in the TO field (134.58 KB, image/png)
2011-10-03 08:46 UTC, nomnex
no flags Details
2a-changing the prefs from auto to address on tab (153.09 KB, image/png)
2011-10-03 08:47 UTC, nomnex
no flags Details
2b-a string of letters can be entred on the TO field (vs. a single char) using "japanese-anthy" (121.60 KB, image/png)
2011-10-03 08:48 UTC, nomnex
no flags Details

Description nomnex 2011-09-09 06:55:31 UTC
Description of problem:

F-15 LXDE, en_US, keyboard JP. I Japanese-Anthy, with the default shortcuts, to input Japanese.

Anthy on-off: Ctrl+J
Circle input method: Ctrl+, (Hiragana, Katakana, Romaji)

There are 2 things that don't work as long as I use Japanese-Anthy

1:
I cannot enter Macron letters when I type Romaji. Example: "Tookyoo" is "Tōkyō". I use "Shift+Control+u 014D": it works with default input, it works with ibus French-Canadian, but it does not work with Japanes-Anthy set to English (_A) or set to "off".

2:
Sylpheed is the default email client on Fedora LXDE.
As long as the input method is set to Anthy, I cannot enter the email of a contact in the "To" "Cc" or "BBc" fields.

Reproduce:
1. Anthy-ibus (either set to off, either set to _A - to type English)
2. In Sylpheed Ctrl+ (Open new message)
3. "To" field: only a single letter can be entered.

Additional info:
I would like to leave my input set to Japanse-Anthy in permanence but currently, I cannot input Romaji letters with Maccrons, and I cannot send emails to my contacts unless I turn input off (Ctrl+Space) or set the ibus to another input than Japanese.

Comment 1 fujiwara 2011-09-09 07:41:01 UTC
(In reply to comment #0)
> 1:
> I cannot enter Macron letters when I type Romaji. Example: "Tookyoo" is
> "Tōkyō". I use "Shift+Control+u 014D": it works with default input, it works
> with ibus French-Canadian, but it does not work with Japanes-Anthy set to
> English (_A) or set to "off".

What do you mean in 'set to "off" here?
I know The Anthy Latin mode (_A) does not work with Control+Shift+u.
But I think you can use Control+Shift+u if you type Control+Space, but not Control+j, to disable anthy (Turn off input method) so I wonder if you'd like to use C+S+u with enabled anthy.

> 2:
> Sylpheed is the default email client on Fedora LXDE.
> As long as the input method is set to Anthy, I cannot enter the email of a
> contact in the "To" "Cc" or "BBc" fields.

I think this is not an ibus issue but a sylpheed issue but I cannot reproduce your problem.
I can type any chars in "To", "Cc" or "Bcc" fields.
Could you attached the screenshot?

% gnome-panel-screenshot --delay 5

Comment 2 nomnex 2011-09-12 06:03:57 UTC
Thank you for the prompt (as always) feedback.

(In reply to comment #1)

> What do you mean in 'set to "off" here?

Japanese Anthy > Ctrl J

> Control+j, to disable anthy (Turn off input method) so I wonder if you'd like
> to use C+S+u with enabled anthy.

That is correct. Ideally, I would rather stay in the same environment (anthy), and circle input methods when needed, e.g. when I type French (vs. having to turn on-off the input method (Crtl+space) anytime I type in Romaji.

> I think this is not an ibus issue but a sylpheed issue but I cannot reproduce
> your problem.
> I can type any chars in "To", "Cc" or "Bcc" fields.

This one's bit odd. On my system, ibus conflicts with Sylpheed's setting; Common prefs>details>other>address book>auto-completion: Automatic. When ibus is on, I can only enter a single character (see print-screen) in the "To", "Cc", "Bcc". The problem does not occur if I set the auto-completion: Start with Tab.

---

Addition question*:
I haven't been lucky on ibus google group, so I try my luck her:

I use 3 different input languages (US, JP, FR). My notebook(s) is Japanese (JP keyboard). I would like to rely on ibus for the 3 different inputs (and circle them).
- Setting Japanese was no problem
- Setting Canadian French (with your help) was no problem, it only needed to add the French keyboard in the ibus advanced option
- I can't set the US input using the Japanese keyboard (it always default to a US keyboard of some sort).

With my current setting, every time I need to type in English, I must turn ibus off (Ctrl+Space).

*let me know if you want me re-post the last out-of-topic question elsewhere.

Comment 3 nomnex 2011-09-12 06:05:07 UTC
Created attachment 522648 [details]
ibus+enter contact in sylpheed

Comment 4 nomnex 2011-09-29 04:50:24 UTC
I have seen the bug status change, and you must be busy. But, if you find the time to answer my last question: setting ibus with "en_US" input with a "JP" keyboard - can I do it? That would be great.

Comment 5 fujiwara 2011-09-30 08:38:25 UTC
I still cannot reproduce the sylpheed issue.
I'd ask you to try that issue with a new user account instead of the current user one.

I'll treat this bug for ibus-anthy compose only as RFE.
I think it won't be on time for Fedora 16 release. 

(In reply to comment #4)
> I have seen the bug status change, and you must be busy. But, if you find the
> time to answer my last question: setting ibus with "en_US" input with a "JP"
> keyboard - can I do it? That would be great.

Probably I don't understand your question. If you would choose 'English - English (US)' on ibus panel status icon menu, the US layout could be available with your JP physical keyboard.
Please try to use the latest ibus 1.4.0:
# yum install --enablerepo=updates-testing ibus

I guess your issue is moved to bug 742112.

Comment 6 nomnex 2011-10-03 08:44:11 UTC
(In reply to comment #5)
> I still cannot reproduce the sylpheed issue.
> I'd ask you to try that issue with a new user account instead of the current
> user one.

same result, using a new account and another notebook running LXDE spin F-15.

do you do the following steps (see below + the 4 print-screens)?

a. set ibus to "Japanese-anthy" (kana default)
b. switch "Japanese-anthy" off (not ibus input method) using "Ctrl+J" - the language bar switch from ”あ” to "_A"
c. open sylpheed and create a new message
c.2. in the To field (common prefs > Details > Address book > Automatic (that's the default setting)) enter a first letter e.g. "a", you will see the menu with all your "A" named contacts
c.3 type a second letter, e.g. "b", to narrow the menu with only your "ab..." named contacts - That does not work. a second letter on the "To" field or any address field cannot be entered as long as ibus is set to "japanese-anthy" & sylpheed pref. is set to "auto".
c.4 Change the sylpheed pref from "auto" to "start with tab" you will re-gain the ability to type more than 1 single character in the address field.



> (In reply to comment #4)
> > my last question: setting ibus with "en_US" input with a "JP"
> > keyboard - can I do it? That would be great.
> 
> Probably I don't understand your question. If you would choose 'English -
> English (US)' on ibus panel status icon menu, the US layout could be available
> with your JP physical keyboard.

I try again.

My default system keyboard layout is "JP", my default language is "en_US"

Ibus Japanese is fine:
I set language: Japanese
Advance pref: keyboard layout "jp"

Ibus Canadian French is also fine:
I set language: French Canadian
Advance pref: keyboard layout "fr_ca"

I have a problem setting ibus in English:
When I set language: English (us), ibus automatically default to the keyboard layout to "en_us".
When I go to advanced pref to change keyboard layout, I can set, e.g. "us_dvorak, en_international,..." but I don't find a way -- in the ibus prefs -- to set language: "English US" and keyboard layout: "jp" (vs. us_en).

Can I do that?

So to sum up, I would like to use ibus set to English (US) input language WITH my "jp" keyboard layout - and that does not work.

> Please try to use the latest ibus 1.4.0:
> # yum install --enablerepo=updates-testing ibus

I understand what you meant in the other comments by "run the latest ibus" you meant the "testing version", not the "repo version" - I got it know!

Comment 7 nomnex 2011-10-03 08:45:32 UTC
Created attachment 525998 [details]
1a - default address prefs

Comment 8 nomnex 2011-10-03 08:46:34 UTC
Created attachment 525999 [details]
1b-Japanese anthy set, only a single letter can be entred in the TO field

Comment 9 nomnex 2011-10-03 08:47:20 UTC
Created attachment 526000 [details]
2a-changing the prefs from auto to address on tab

Comment 10 nomnex 2011-10-03 08:48:23 UTC
Created attachment 526001 [details]
2b-a string of letters can be entred on the TO field (vs. a single char) using "japanese-anthy"

Comment 11 Akira TAGOH 2012-06-06 09:56:24 UTC
Fujiwara-san, any updates?

Comment 12 Fedora Update System 2013-09-09 06:33:44 UTC
ibus-anthy-1.5.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.4-1.fc19

Comment 13 Fedora Update System 2013-09-09 06:34:08 UTC
ibus-anthy-1.5.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.4-1.fc18

Comment 14 Fedora Update System 2013-09-09 06:34:22 UTC
ibus-anthy-1.5.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.4-1.fc20

Comment 15 Fedora Update System 2013-09-09 16:20:18 UTC
Package ibus-anthy-1.5.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-anthy-1.5.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16146/ibus-anthy-1.5.4-1.fc20
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-09-18 13:01:39 UTC
ibus-anthy-1.5.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-09-18 13:07:17 UTC
ibus-anthy-1.5.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2013-09-23 00:39:28 UTC
ibus-anthy-1.5.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.