Bug 737164 - Missing firmware for Atheros AR9170 WLAN chip in F15, F16
Summary: Missing firmware for Atheros AR9170 WLAN chip in F15, F16
Keywords:
Status: CLOSED DUPLICATE of bug 866051
Alias: None
Product: Fedora
Classification: Fedora
Component: ar9170-firmware
Version: 16
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 674930 674931
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 19:08 UTC by Nikolaus Waxweiler
Modified: 2012-10-31 17:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-31 17:02:02 UTC


Attachments (Terms of Use)

Description Nikolaus Waxweiler 2011-09-09 19:08:02 UTC
Description of problem:
Both current F15 and graphics_test_week-20110905-x64.iso (F16?) miss the firmware for the Atheros AR9170 chip, so it cannot be used out of the box. This firmware became necessary with kernel 3.0 I think, when the ar9170 driver was removed and replaced by the carl9170 driver. Please include it before the release.

Additional info:
http://linuxwireless.org/en/users/Drivers/carl9170.fw

Comment 1 Nikolaus Waxweiler 2011-10-06 13:07:45 UTC
Still not present in F16 Beta. I'm using the TP-Link TL-WN822N (USB), by the way.

Comment 2 Ryan K 2012-09-08 20:30:42 UTC
Still not present in Fedora 17. The firmware is GPL licensed so I don't believe there would be any problem including it.

Download from
linuxwireless.org/en/users/Drivers/carl9170#carl9170-1

Comment 3 John W. Linville 2012-10-31 17:02:02 UTC

*** This bug has been marked as a duplicate of bug 866051 ***


Note You need to log in before you can comment on or make changes to this bug.