Bug 866051 - carl9170 fw missing in distribution
carl9170 fw missing in distribution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
http://linuxwireless.org/en/users/Dri...
:
: 737164 889860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 08:54 EDT by Account closed by user
Modified: 2013-02-01 15:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 15:11:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
changes for building in Fedora (6.80 KB, patch)
2012-11-27 07:09 EST, Dan Horák
no flags Details | Diff

  None (edit)
Description Account closed by user 2012-10-13 08:54:36 EDT
please,

add carl9170-1.fw to Fedora: http://linuxwireless.org/en/users/Drivers/carl9170#Firmware-1
Comment 1 Josh Boyer 2012-10-14 11:42:24 EDT
The linux-firmware package only provides firmware found in the upstream linux-firmware git tree.  The carl9170 firmware is open sourced, but it is separate from this package and requires a sh2 cross-compiler to build.  It would need to be packaged separately.
Comment 2 John W. Linville 2012-10-15 15:29:13 EDT
Yes.  I had started down this road some time back, but got stuck on the toolchain packages.  David Howells seems to have worked that out, so maybe progress can resume...
Comment 3 Bill Nottingham 2012-10-15 15:31:14 EDT
Could it be packaged as a 'normal' firmware even though it happens to be open-sourced? (I suppose that's cheating, but it's simpler.) What's the license?
Comment 4 John W. Linville 2012-10-15 15:43:22 EDT
It's GPLv2+.
Comment 5 Bill Nottingham 2012-10-15 15:45:45 EDT
OK, then that's a little more problematic. Never mind.
Comment 7 John W. Linville 2012-10-31 10:41:59 EDT
Dan, have you done any further work on this?  Is the current gcc-sh-linux-gnu package acceptable for building the carl9170 firmware?
Comment 8 John W. Linville 2012-10-31 13:02:02 EDT
*** Bug 737164 has been marked as a duplicate of this bug. ***
Comment 9 Dan Horák 2012-10-31 16:18:29 EDT
(In reply to comment #7)
> Dan, have you done any further work on this?  Is the current
> gcc-sh-linux-gnu package acceptable for building the carl9170 firmware?

I've tried now and while the gcc-sh-linux-gnu compiler has teh SH2 support it fails for me with 

/usr/bin/cmake -H/opt2/src/carl9170fw -B/opt2/src/carl9170fw --check-build-system CMakeFiles/Makefile.cmake 0
/usr/bin/cmake -E cmake_progress_start /opt2/src/carl9170fw/CMakeFiles /opt2/src/carl9170fw/CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory `/opt2/src/carl9170fw'
make -f carlfw/CMakeFiles/carl9170.elf.dir/build.make carlfw/CMakeFiles/carl9170.elf.dir/depend
make[2]: Entering directory `/opt2/src/carl9170fw'
cd /opt2/src/carl9170fw && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /opt2/src/carl9170fw /opt2/src/carl9170fw/carlfw /opt2/src/carl9170fw /opt2/src/carl9170fw/carlfw /opt2/src/carl9170fw/carlfw/CMakeFiles/carl9170.elf.dir/DependInfo.cmake --color=
make[2]: Leaving directory `/opt2/src/carl9170fw'
make -f carlfw/CMakeFiles/carl9170.elf.dir/build.make carlfw/CMakeFiles/carl9170.elf.dir/build
make[2]: Entering directory `/opt2/src/carl9170fw'
/usr/bin/cmake -E cmake_progress_report /opt2/src/carl9170fw/CMakeFiles 1
[  3%] Building C object carlfw/CMakeFiles/carl9170.elf.dir/src/main.c.o
cd /opt2/src/carl9170fw/carlfw && sh-linux-gnu-gcc   -m2 -ml -Os -ffreestanding -fleading-underscore -nostartfiles -I/opt2/src/carl9170fw/carlfw/../include/linux -I/opt2/src/carl9170fw/carlfw/../include/shared -I/opt2/src/carl9170fw/carlfw/../include -I/opt2/src/carl9170fw/carlfw/include    -D__CARL9170FW__ -mbitops -std=gnu99 -ffunction-sections -Wframe-larger-than=128 -Werror -fomit-frame-pointer -fsee -frename-registers -ftree-vectorize -flto -fstrict-volatile-bitfields -fmodulo-sched -fwhole-program -W -Wall -Wextra -Wunreachable-code -Winline -Wlogical-op -Wno-packed-bitfield-compat -Winit-self -Wshadow -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wformat=2 -Wcast-align -Wmissing-format-attribute -Wmissing-prototypes -Wtype-limits -Wmissing-declarations -Wmissing-noreturn -Wredundant-decls -Wnested-externs -Wdisabled-optimization -Wpointer-arith -Wvolatile-register-var -Waddress -Wbad-function-cast -Wunsafe-loop-optimizations -o CMakeFiles/carl9170.elf.dir/src/main.c.o   -c /opt2/src/carl9170fw/carlfw/src/main.c
In file included from /opt2/src/carl9170fw/carlfw/include/config.h:19:0,
                 from /opt2/src/carl9170fw/carlfw/include/carl9170.h:28,
                 from /opt2/src/carl9170fw/carlfw/src/main.c:26:
/opt2/src/carl9170fw/carlfw/../include/linux/types.h:25:2: error: #error "big endian is not supported by target"
make[2]: *** [carlfw/CMakeFiles/carl9170.elf.dir/src/main.c.o] Error 1
make[2]: Leaving directory `/opt2/src/carl9170fw'
make[1]: *** [carlfw/CMakeFiles/carl9170.elf.dir/all] Error 2
make[1]: Leaving directory `/opt2/src/carl9170fw'
make: *** [all] Error 2

when build carl9170 from git + my patch I've send to the kernel list, the "-ml" option should make the compiler produce little endian output ... I will try to look better on it.
Comment 10 Dan Horák 2012-11-27 05:02:20 EST
So I've fixed a number of little issues in both our SH toolchain and the carlfw buildsystem and things look promissing, stay tuned :-)
Comment 11 Dan Horák 2012-11-27 07:09:09 EST
Created attachment 652642 [details]
changes for building in Fedora

this is a patch against carlfw master for building with the Fedora SH cross-toolchain (needs updated packages which are not built yet)
Comment 12 John W. Linville 2013-01-02 10:38:05 EST
*** Bug 889860 has been marked as a duplicate of this bug. ***
Comment 13 Josh Boyer 2013-01-23 14:19:36 EST
OK, so Xose has gone and gotten this into the upstream linux-firmware git repo.  It contains the source code, scripts to build a toolchain, and a pre-built copy of the firmware.  See http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary

The question now becomes can we include and distribute the pre-built copy.  I'm going to block this on FE-Legal for now to see if there are any concerns there.
Comment 14 Account closed by user 2013-01-25 10:48:45 EST
(In reply to comment #13)

> OK, so Xose has gone and gotten this into the upstream linux-firmware git
> repo.  It contains the source code, scripts to build a toolchain, and a
> pre-built copy of the firmware.  See
> http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;
> a=summary

Dan Horák is aware of that. I did put him in Cc: in this thread:
http://marc.info/?l=linux-wireless&m=135829349722977
http://marc.info/?l=linux-wireless&m=135845803025773
http://marc.info/?l=linux-wireless&m=135846673629484

> The question now becomes can we include and distribute the pre-built copy. 
> I'm going to block this on *FE-Legal* for now to see if there are any concerns
> there.

This is going to take forever.
Comment 15 Tom "spot" Callaway 2013-01-25 14:20:38 EST
This is fine. Obviously, it would be preferable for this firmware to be built from source, but as long as the corresponding source code is also included in the Source RPM package, it is okay as a special exception. (I'm treating this as being in the same situation as a QEMU firmware).

Lifting FE-Legal.
Comment 16 Josh Boyer 2013-01-25 14:44:19 EST
(In reply to comment #15)
> This is fine. Obviously, it would be preferable for this firmware to be
> built from source, but as long as the corresponding source code is also
> included in the Source RPM package, it is okay as a special exception. (I'm
> treating this as being in the same situation as a QEMU firmware).
> 
> Lifting FE-Legal.

Great.  I'll update the linux-firmware package early next week to include this then.
Comment 17 Josh Boyer 2013-02-01 15:11:03 EST
This should be fixed in rawhide.  An update for F18 will eventually make its way out.

Note You need to log in before you can comment on or make changes to this bug.