Bug 737247 - logwatch/up2date fix and extension
logwatch/up2date fix and extension
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.1
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
Ondrej Hudlicky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-10 06:38 EDT by Yury V. Zaytsev
Modified: 2014-01-30 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 548117
Environment:
Last Closed: 2013-09-10 09:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (572 bytes, patch)
2013-06-06 03:52 EDT, Jan Synacek
no flags Details | Diff
Reproducer (143 bytes, application/x-sh)
2013-06-06 08:19 EDT, Jan Synacek
no flags Details

  None (edit)
Description Yury V. Zaytsev 2011-09-10 06:38:35 EDT
+++ This bug was initially created as a clone of Bug #548117 +++

Description of problem:
logwatch's up2date service misses at least one fix for a changed logging line of the yum-rhn-plugin and also I have 2 extensions for an extension requested for yum-rhn-plugin

Version-Release number of selected component (if applicable):
logwatch-7.3-6.el5

How reproducible:
Always

Steps to Reproduce:
1. always
  
Actual results:
 --------------------- up2date Begin ------------------------

 **Unmatched Entries**
 updateLoginInfo() login info

 ---------------------- up2date End -------------------------



Expected results:
Not such message

Additional info:

Following extension fixes this problem:

--- /usr/share/logwatch/scripts/services/up2date.orig   2009-12-16 16:47:04.000000000 +0000
+++ /usr/share/logwatch/scripts/services/up2date        2009-12-16 17:03:31.000000000 +0000
@@ -25,6 +25,7 @@
       $DebugCounter++;
    }
    if ( ( $ThisLine =~ /^updating login info$/ ) or
+        ( $ThisLine =~ /^updateLoginInfo\(\) login info$/ ) or
         ( $ThisLine =~ /^Opening rpmdb in \/var\/lib\/rpm\/ with option .$/ ) or
         ( $ThisLine =~ /^successfully retrieved authentication token from up2date server$/ ) or
         ( $ThisLine =~ /^(getA|a)vailablePackageList from network$/ ) or


Note: it can be seen that log line had only small changes sometime in the past


And please add also following extension for my requested extension of logging of yum-rhn-plugin https://bugzilla.redhat.com/show_bug.cgi?id=548111

@@ -47,10 +48,14 @@
       # We don't care about these
    } elsif ( $ThisLine =~ s/^installing packages: ([^ ]+)/$1/ ) {
       $PackageInstalled{$ThisLine}++;
+   } elsif ( $ThisLine =~ s/^Installed: ([^ ]+)/$1/ ) {
+      $PackageInstalled{$ThisLine}++;
    } elsif ( $ThisLine =~ s/^Adding packages to package profile: ([^ ]+)/$1/ ) {
       $PackageAddedToProfile{$ThisLine}++;
    } elsif ( $ThisLine =~ s/^Removing packages from package profile: ([^ ]+)/$1/ ) {
       $PackageRemovedFromProfile{$ThisLine}++;
+   } elsif ( $ThisLine =~ s/^Erased: ([^ ]+)/$1/ ) {
+      $PackageRemovedFromProfile{$ThisLine}++;
    } else {
       # Report any unmatched entries...
       push @OtherList,$ThisLine;

--- Additional comment from pb@bieringer.de on 2009-12-16 12:06:18 EST ---

Created attachment 378794 [details]
Extension for  /usr/share/logwatch/scripts/services/up2date

--- Additional comment from kklic@redhat.com on 2010-04-12 05:57:46 EDT ---

Hello,

now it seems only the following part needs a fix:
 **Unmatched Entries**
 updateLoginInfo() login info

--- Additional comment from kklic@redhat.com on 2010-04-12 06:02:34 EDT ---

This is a candidate for fastrack.

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 15:29:39 EST ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 18:02:09 EST ---

This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

--- Additional comment from pm-rhel@redhat.com on 2011-05-31 09:23:01 EDT ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from yury@shurup.com on 2011-09-08 08:00:30 EDT ---

This is also relevant to RHEL6. Could someone please clone this bug?
Comment 2 RHEL Product and Program Management 2011-09-10 07:07:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Jan Synacek 2013-06-06 03:52:46 EDT
Created attachment 757537 [details]
Patch
Comment 7 Jan Synacek 2013-06-06 08:19:48 EDT
Created attachment 757646 [details]
Reproducer

How to test:

1) sh test.sh
2 - before) output with **Unmatched Entries**
2 - after) no output
Comment 12 errata-xmlrpc 2013-09-10 09:39:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1247.html

Note You need to log in before you can comment on or make changes to this bug.