Bug 737306 - AttributeError: 'NoneType' object has no attribute 'path'
Summary: AttributeError: 'NoneType' object has no attribute 'path'
Keywords:
Status: CLOSED DUPLICATE of bug 743647
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:050f1e3abd2b51b09859325bd7e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 22:55 UTC by Diego Calleja
Modified: 2011-10-06 09:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-06 09:04:52 UTC


Attachments (Terms of Use)

Description Diego Calleja 2011-09-10 22:55:50 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
time:           Sat Sep 10 22:54:39 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 2252, in mkDevRoot
:    dev = "%s/%s" % (instPath, root.path)
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 1314, in mkDevRoot
:    self.fsset.mkDevRoot()
:  File "/tmp/updates/pyanaconda/upgrade.py", line 241, in upgradeMountFilesystems
:    anaconda.storage.mkDevRoot()
:  File "/tmp/updates/pyanaconda/dispatch.py", line 360, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/tmp/updates/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:AttributeError: 'NoneType' object has no attribute 'path'

Comment 1 Diego Calleja 2011-09-10 23:04:16 UTC
I would like to point out that this happened after using the update image from Ales Kozumplik, mentioned here: https://bugzilla.redhat.com/show_bug.cgi?id=728188#c10 (I hit the error mentioned in that bug)

Also, my filesystem setup is a multidevice btrfs setup with a real "root" F15 filesystem living in a btrfs subvolume.

Comment 2 Ales Kozumplik 2011-09-12 06:28:09 UTC
(In reply to comment #1)
> I would like to point out that this happened after using the update image from
> Ales Kozumplik, mentioned here:
> https://bugzilla.redhat.com/show_bug.cgi?id=728188#c10 (I hit the error
> mentioned in that bug)
> 

That image is one month old (containing all the old files). Please retest in the latest F16.

Comment 3 Diego Calleja 2011-09-12 16:24:38 UTC
Sadly I can't fully test it, because anaconda still doesn't support btrfs subvolumes. But until the partition selection phase I didn't have failures, so I guess it has been fixed...

Comment 4 Diego Calleja 2011-10-05 15:26:33 UTC
I must reopen this bug: I just tried preupgrade with the new F16 Beta and I had an error. When I tried to report it the bug reporter said me that it was a duplicate of this bug...

Comment 5 Chris Lumens 2011-10-05 15:30:36 UTC
Please attach the traceback you are getting - that'd be the /tmp/anaconda-tb-* file.  Thanks.

Comment 6 Diego Calleja 2011-10-05 16:05:59 UTC
I just filed a new bug that I got after trying the install DVD instead of using preupgrade...and I just realized that the python traceback seems similar and it may be the same bug. Since that bug already has attached the anaconda traceback, maybe this bug should be closed?

Comment 7 Diego Calleja 2011-10-05 16:07:05 UTC
(the new bug is #743647)

Comment 8 Ales Kozumplik 2011-10-06 09:04:52 UTC

*** This bug has been marked as a duplicate of bug 743647 ***


Note You need to log in before you can comment on or make changes to this bug.