Bug 728188 - upgrade failed from f15 to f16, Dispatch error:cannot reschedule step 'findinstall' from 'skipped' to 'requested'
upgrade failed from f15 to f16, Dispatch error:cannot reschedule step 'findin...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 731255 (view as bug list)
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-04 06:27 EDT by Hongqing Yang
Modified: 2014-09-30 19:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-16.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 22:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (7.41 KB, text/plain)
2011-08-04 06:28 EDT, Hongqing Yang
no flags Details
syslog (64.11 KB, text/plain)
2011-08-04 06:28 EDT, Hongqing Yang
no flags Details
program log (25.28 KB, text/plain)
2011-08-04 06:29 EDT, Hongqing Yang
no flags Details
upgrade logs (690.00 KB, application/x-tar)
2011-08-05 22:31 EDT, Hongqing Yang
no flags Details
upgrade log with updates image2 (6.11 MB, application/x-tar)
2011-08-08 03:32 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-08-04 06:27:24 EDT
Description of problem:

upgrade failed from f15 to f16, Dispatch error:cannot reschedule step 'findinstall' from 'skipped' to 'requested' 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. install previous release
2. upgrade f16 from DVD
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-08-04 06:28:08 EDT
Created attachment 516679 [details]
anaconda.log
Comment 2 Hongqing Yang 2011-08-04 06:28:34 EDT
Created attachment 516680 [details]
syslog
Comment 3 Hongqing Yang 2011-08-04 06:29:04 EDT
Created attachment 516681 [details]
program log
Comment 4 Ales Kozumplik 2011-08-05 09:59:50 EDT
Hi, can you please retest with:
http://akozumpl.fedorapeople.org/bz_dispatcher.img

And see if it fixes the problem or attach the new traceback?

Thanks.
Comment 5 James Laska 2011-08-05 11:50:44 EDT
Proposing as a F16Beta release blocker due to the following criteria ...
   "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria "
Comment 6 Hongqing Yang 2011-08-05 22:30:21 EDT
(In reply to comment #4)
> Hi, can you please retest with:
> http://akozumpl.fedorapeople.org/bz_dispatcher.img
> 
> And see if it fixes the problem or attach the new traceback?
> 
> Thanks.

I have tested it, error still occured:

cannot reschedule step  'cleardiskssel' from 'skipped' to 'requested'. logs can be found in the attachment log.tar
Comment 7 Hongqing Yang 2011-08-05 22:31:19 EDT
Created attachment 516971 [details]
upgrade logs
Comment 8 Hongqing Yang 2011-08-05 22:48:44 EDT
*** Bug 728122 has been marked as a duplicate of this bug. ***
Comment 9 Hongqing Yang 2011-08-06 03:01:24 EDT
this is reproduced on f16-alpha-rc1
Comment 10 Ales Kozumplik 2011-08-08 03:06:12 EDT
Hi, thanks for the testing, I made a new image updates image which is supposed to fix the error from comment 7:

http://akozumpl.fedorapeople.org/bz_dispatcher2.img

Can you please try it?
Comment 11 Hongqing Yang 2011-08-08 03:31:23 EDT
Hi, Ales,

The "'NoneType' object is not subscriptable" error occured, please find the details from the attachments.
Comment 12 Hongqing Yang 2011-08-08 03:32:17 EDT
Created attachment 517123 [details]
upgrade log with updates image2
Comment 13 Ales Kozumplik 2011-08-08 03:53:38 EDT
(In reply to comment #11)
> Hi, Ales,
> 
> The "'NoneType' object is not subscriptable" error occured, please find the
> details from the attachments.

I think you are hitting a new error, because the logs show you moved past the original point of failure. I am going to push my fix, once it gets into f16 builds (post alpha probably?) you can open the new bug.
Comment 14 Ales Kozumplik 2011-08-08 03:55:18 EDT
Proposed patch:

https://www.redhat.com/archives/anaconda-devel-list/2011-August/msg00080.html.
Comment 15 Ales Kozumplik 2011-08-09 03:55:04 EDT
Fixed by c3bedc8c5b1542e882824d5fb4005f6336e7822a.
Comment 16 Ales Kozumplik 2011-08-09 04:16:14 EDT
For F16 this will be a part of the first post-alpha Anaconda build.
Comment 17 Chris Bagwell 2011-08-09 23:34:04 EDT
With both Fedora 16 Alpha RC1 and RC3, I get a similar but different dispatch error.

When I click the next button after selecting my Fedora 15 partition to upgrade, I get something like:

Dispatch error:cannot reschedule step 'language' from 'skipped' to 'requested'

I'm unable to save event though (doesn't like my wireless network and doesn't prompt for saving to disk) so this is from memory.

The proposed patch in Comment 14 changes both 'findinstall' (title of this bug) and 'language' to both be schedule_steps_gently().  So its my hopes this will also fix my issue.

I'll retest when updated ISO is available... but I wanted to get the phrase 'language' in comments for benefit of other users getting same  variation of error.

I'm unable to upgrade as-is.
Comment 18 Hongqing Yang 2011-08-09 23:44:09 EDT
(In reply to comment #17)
> With both Fedora 16 Alpha RC1 and RC3, I get a similar but different dispatch
> error.
> 
> When I click the next button after selecting my Fedora 15 partition to upgrade,
> I get something like:
> 
> Dispatch error:cannot reschedule step 'language' from 'skipped' to 'requested'
> 
> I'm unable to save event though (doesn't like my wireless network and doesn't
> prompt for saving to disk) so this is from memory.
> 
> The proposed patch in Comment 14 changes both 'findinstall' (title of this bug)
> and 'language' to both be schedule_steps_gently().  So its my hopes this will
> also fix my issue.
> 
> I'll retest when updated ISO is available... but I wanted to get the phrase
> 'language' in comments for benefit of other users getting same  variation of
> error.
> 
> I'm unable to upgrade as-is.

Your bug is the same with bug 728122
Comment 19 Chris Bagwell 2011-08-15 23:51:08 EDT
Thanks for pointer that bug 728112 is what I was seeing.  I just tried RC4 with anaconda 16.14.5 and still see issue. I do not know if the comment 14 patch was ever committed.

anaconda 16.14.5 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 98, in _r
eschedule
    self.namesched(to_sched)))
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 148, in s
chedule
    return self._reschedule(self.SCHED_SCHEDULED, current_step)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in <
lambda>
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 308, in s
chedule_steps
    changes = map(lambda s: self.steps[s].schedule(self._current_step()), steps)
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 288, in se
tSteps
    "complete"
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/examine_gui.py", line 43,
 in getNext
    upgrade.setSteps(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1194, in nextC
licked
    rc = self.currentWindow.getNext ()
DispatchError: Can not reschedule step 'language' from 'skipped' to 'scheduled'
Comment 20 Ales Kozumplik 2011-08-16 02:06:36 EDT
It was committed but it won't make Alpha. The problems with the dispatcher exist because I made a bunch of cleanups to it during f16 development and those are errors coming back. Since the upgrade path is not considered as critical for alpha we decided not to merge the latest fixes there and make the branch stable for the basic install sooner instead.
Comment 21 James Laska 2011-08-16 07:51:13 EDT
Adding keyword 'CommonBugs' to this issue so the problem can be documented until the bug is resolved in a post-Alpha anaconda build.
Comment 22 Ales Kozumplik 2011-08-17 04:36:10 EDT
*** Bug 731255 has been marked as a duplicate of this bug. ***
Comment 23 Tim Flink 2011-09-01 13:23:23 EDT
Discussed in the 2011-08-26 blocker review meeting. Accepted as a Fedora 16 beta blocker as it violates the following beta release criterion [1]:

The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria

[1] https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 24 Adam Williamson 2011-09-07 17:22:25 EDT
Hongqing, can you please confirm the status of this bug with Beta TC1? Thanks!
Comment 25 Adam Williamson 2011-09-12 17:32:39 EDT
In my testing, this bug is fixed in TC2, and you run into https://bugzilla.redhat.com/show_bug.cgi?id=735730 later in install. Moving to VERIFIED for now, but it should probably be CLOSED. Hongqing, if you could confirm that would be great.

Note You need to log in before you can comment on or make changes to this bug.