Bug 737381 - SELinux is preventing /bin/ln from 'write' accesses on the directory rules.d.
Summary: SELinux is preventing /bin/ln from 'write' accesses on the directory rules.d.
Keywords:
Status: CLOSED DUPLICATE of bug 737380
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:581bb823f8acac629eea7aed108...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 17:48 UTC by frywalker
Modified: 2011-09-12 11:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 11:32:58 UTC


Attachments (Terms of Use)

Description frywalker 2011-09-11 17:48:54 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /bin/ln from 'write' accesses on the directory rules.d.
time:           Sun Sep 11 19:48:09 2011

description:
:SELinux is preventing /bin/ln from 'write' accesses on the directory rules.d.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ln should be allowed write access on the rules.d directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ln /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:udev_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:udev_rules_t:s0
:Target Objects                rules.d [ dir ]
:Source                        ln
:Source Path                   /bin/ln
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.12-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux fedora16 3.0.0-1.fc16.x86_64 #1 SMP Fri Jul
:                              22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 11 Sep 2011 07:39:35 PM CEST
:Last Seen                     Sun 11 Sep 2011 07:39:35 PM CEST
:Local ID                      b5fa63f9-e9fa-40db-8137-27f5ed0f2fa2
:
:Raw Audit Messages
:type=AVC msg=audit(1315762775.915:68): avc:  denied  { write } for  pid=1776 comm="ln" name="rules.d" dev=dm-2 ino=2361182 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1315762775.915:68): avc:  denied  { add_name } for  pid=1776 comm="ln" name=".is-writeable" scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1315762775.915:68): avc:  denied  { create } for  pid=1776 comm="ln" name=".is-writeable" scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1315762775.915:68): arch=x86_64 syscall=symlink success=yes exit=0 a0=7fff99fdfcea a1=7fff99fdfcf4 a2=0 a3=7fff99fdebc0 items=0 ppid=1766 pid=1776 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ln exe=/bin/ln subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: ln,udev_t,udev_rules_t,dir,write
:
:audit2allow
:
:#============= udev_t ==============
:#!!!! The source type 'udev_t' can write to a 'dir' of the following types:
:# var_run_t, xend_var_log_t, net_conf_t, udev_var_run_t, device_t, etc_t, tmpfs_t, hugetlbfs_t, root_t
:
:allow udev_t udev_rules_t:dir { write add_name };
:allow udev_t udev_rules_t:lnk_file create;
:
:audit2allow -R
:
:#============= udev_t ==============
:#!!!! The source type 'udev_t' can write to a 'dir' of the following types:
:# var_run_t, xend_var_log_t, net_conf_t, udev_var_run_t, device_t, etc_t, tmpfs_t, hugetlbfs_t, root_t
:
:allow udev_t udev_rules_t:dir { write add_name };
:allow udev_t udev_rules_t:lnk_file create;
:

Comment 1 Miroslav Grepl 2011-09-12 11:32:58 UTC

*** This bug has been marked as a duplicate of bug 737380 ***


Note You need to log in before you can comment on or make changes to this bug.