Bug 737380 - SELinux is preventing /bin/rm from 'getattr' accesses on the lnk_file /etc/udev/rules.d/.is-writeable.
Summary: SELinux is preventing /bin/rm from 'getattr' accesses on the lnk_file /etc/ud...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dae5445e4e316ac33a7f8fef100...
: 737381 737383 737384 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 17:48 UTC by frywalker
Modified: 2011-09-12 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 11:32:24 UTC


Attachments (Terms of Use)

Description frywalker 2011-09-11 17:48:15 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /bin/rm from 'getattr' accesses on the lnk_file /etc/udev/rules.d/.is-writeable.
time:           Sun Sep 11 19:44:17 2011

description:
:SELinux is preventing /bin/rm from 'getattr' accesses on the lnk_file /etc/udev/rules.d/.is-writeable.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rm should be allowed getattr access on the .is-writeable lnk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:udev_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:udev_rules_t:s0
:Target Objects                /etc/udev/rules.d/.is-writeable [ lnk_file ]
:Source                        rm
:Source Path                   /bin/rm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.12-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri Jul
:                              22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 11 Sep 2011 07:39:35 PM CEST
:Last Seen                     Sun 11 Sep 2011 07:39:35 PM CEST
:Local ID                      3fb8e008-1e36-44c8-a124-c343e3cd6762
:
:Raw Audit Messages
:type=AVC msg=audit(1315762775.918:69): avc:  denied  { getattr } for  pid=1777 comm="rm" path="/etc/udev/rules.d/.is-writeable" dev=dm-2 ino=2368775 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1315762775.918:69): arch=x86_64 syscall=newfstatat success=yes exit=0 a0=ffffffffffffff9c a1=bc6410 a2=bc6380 a3=100 items=0 ppid=1766 pid=1777 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rm exe=/bin/rm subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: rm,udev_t,udev_rules_t,lnk_file,getattr
:
:audit2allow
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:lnk_file getattr;
:
:audit2allow -R
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:lnk_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-12 11:32:24 UTC
Please update your system. This is fixed in the lates policy release.

# yum update

Comment 2 Miroslav Grepl 2011-09-12 11:32:59 UTC
*** Bug 737381 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2011-09-12 11:33:25 UTC
*** Bug 737383 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2011-09-12 11:33:55 UTC
*** Bug 737384 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.