Bug 737383 - SELinux is preventing /bin/rm from 'remove_name' accesses on the directory .is-writeable.
Summary: SELinux is preventing /bin/rm from 'remove_name' accesses on the directory .i...
Keywords:
Status: CLOSED DUPLICATE of bug 737380
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:762412b89bd8213e8f6a40cbc47...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 17:49 UTC by frywalker
Modified: 2011-09-12 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 11:33:25 UTC


Attachments (Terms of Use)

Description frywalker 2011-09-11 17:49:41 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /bin/rm from 'remove_name' accesses on the directory .is-writeable.
time:           Sun Sep 11 19:48:53 2011

description:
:SELinux is preventing /bin/rm from 'remove_name' accesses on the directory .is-writeable.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rm should be allowed remove_name access on the .is-writeable directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:udev_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:udev_rules_t:s0
:Target Objects                .is-writeable [ dir ]
:Source                        rm
:Source Path                   /bin/rm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.12-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri Jul
:                              22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 11 Sep 2011 07:39:35 PM CEST
:Last Seen                     Sun 11 Sep 2011 07:39:35 PM CEST
:Local ID                      e5dfee09-8cfe-47ac-b159-6e5328ccdd1e
:
:Raw Audit Messages
:type=AVC msg=audit(1315762775.918:70): avc:  denied  { remove_name } for  pid=1777 comm="rm" name=".is-writeable" dev=dm-2 ino=2368775 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1315762775.918:70): avc:  denied  { unlink } for  pid=1777 comm="rm" name=".is-writeable" dev=dm-2 ino=2368775 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1315762775.918:70): arch=x86_64 syscall=unlinkat success=yes exit=0 a0=ffffffffffffff9c a1=bc50f0 a2=0 a3=7fffe94dacf0 items=0 ppid=1766 pid=1777 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rm exe=/bin/rm subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: rm,udev_t,udev_rules_t,dir,remove_name
:
:audit2allow
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:dir remove_name;
:allow udev_t udev_rules_t:lnk_file unlink;
:
:audit2allow -R
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:dir remove_name;
:allow udev_t udev_rules_t:lnk_file unlink;
:

Comment 1 Miroslav Grepl 2011-09-12 11:33:25 UTC

*** This bug has been marked as a duplicate of bug 737380 ***


Note You need to log in before you can comment on or make changes to this bug.