Bug 737384 - SELinux is preventing /bin/bash from 'create' accesses on the file 70-persistent-net.rules.
Summary: SELinux is preventing /bin/bash from 'create' accesses on the file 70-persist...
Keywords:
Status: CLOSED DUPLICATE of bug 737380
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3cf8aa8869ea2eab438046017d7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 17:50 UTC by frywalker
Modified: 2011-09-12 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 11:33:55 UTC


Attachments (Terms of Use)

Description frywalker 2011-09-11 17:50:05 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /bin/bash from 'create' accesses on the file 70-persistent-net.rules.
time:           Sun Sep 11 19:49:23 2011

description:
:SELinux is preventing /bin/bash from 'create' accesses on the file 70-persistent-net.rules.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that bash should be allowed create access on the 70-persistent-net.rules file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep write_net_rules /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:udev_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:udev_rules_t:s0
:Target Objects                70-persistent-net.rules [ file ]
:Source                        write_net_rules
:Source Path                   /bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.10-4.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri Jul
:                              22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 11 Sep 2011 07:39:35 PM CEST
:Last Seen                     Sun 11 Sep 2011 07:39:35 PM CEST
:Local ID                      36ea2dcd-1c43-4b27-b42b-3d4240caa39a
:
:Raw Audit Messages
:type=AVC msg=audit(1315762775.962:71): avc:  denied  { create } for  pid=1766 comm="write_net_rules" name="70-persistent-net.rules" scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=file
:
:
:type=AVC msg=audit(1315762775.962:71): avc:  denied  { append } for  pid=1766 comm="write_net_rules" name="70-persistent-net.rules" dev=dm-2 ino=2368775 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_rules_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1315762775.962:71): arch=x86_64 syscall=open success=yes exit=ESRCH a0=11cad30 a1=441 a2=1b6 a3=7265702d30372f64 items=0 ppid=1754 pid=1766 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=write_net_rules exe=/bin/bash subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: write_net_rules,udev_t,udev_rules_t,file,create
:
:audit2allow
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:file { create append };
:
:audit2allow -R
:
:#============= udev_t ==============
:allow udev_t udev_rules_t:file { create append };
:

Comment 1 Miroslav Grepl 2011-09-12 11:33:55 UTC

*** This bug has been marked as a duplicate of bug 737380 ***


Note You need to log in before you can comment on or make changes to this bug.