Bug 737430 - Installing boot loader to /dev/sda not an option.
Installing boot loader to /dev/sda not an option.
Status: CLOSED DUPLICATE of bug 750469
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-11 22:53 EDT by Jordan Clarke
Modified: 2011-11-02 04:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-01 00:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
storage.log (69.18 KB, text/plain)
2011-10-30 20:10 EDT, Samuel Sieb
no flags Details
anaconda.log (10.31 KB, text/plain)
2011-10-30 20:12 EDT, Samuel Sieb
no flags Details
program.log (31.62 KB, text/plain)
2011-10-30 20:12 EDT, Samuel Sieb
no flags Details

  None (edit)
Description Jordan Clarke 2011-09-11 22:53:20 EDT
Description of problem:
When installing Fedora 16 Beta TC2, the only places allowed to install the boot loader were /dev/sdb and /dev/sda1.  The desired target, /dev/sda, wasn't an option.

Version-Release number of selected component (if applicable):


How reproducible:
Observed once, but only attempted once.

Steps to Reproduce:
1. Write Fedora 16 Beta TC2 (Desktop) Live to a USB flash drive using UNetbootin.
2. Boot F16 and begin installation, and successfully complete all prompts to install F16 to /dev/sda until the install boot loader prompt is reached.  (A custom partition layout was successfully used.)
3. Observe the locations the boot loader can be installed to.
  
Actual results:
The boot loader was installed to /dev/sdb, the USB flash drive the live image was on.

Expected results:
The boot loader would be installed to /dev/sda, the location F16 was installed to.

Additional info:
Partition layout

/dev/sda
Size    Dir     FS                      Format
512     /boot   btrfs                   Yes
16384   /       ext4                    Yes
8192    /home   btrfs                   Yes
4096    swap    swap                    Yes

/dev/sdb
Size   Dir     FS
998            EFI System Partition    No
Comment 1 David Lehman 2011-09-28 13:30:34 EDT
Can you attach /tmp/storage.log, /tmp/anaconda.log, and /tmp/program.log to this bug report? If so, please attach them individually as text/plain. Thanks.
Comment 2 Samuel Sieb 2011-10-30 20:10:54 EDT
Created attachment 530869 [details]
storage.log

I'm having the same problem trying to upgrade from F15 to F16 RC2.  I'm using the net installer iso on a USB flash drive.  I had the choice of skipping the bootloader or creating a new one, no updating.  I assume this is because of the change to GRUB2.  When I get to the point of actually installing the bootloader, the drives are switched as they have always been, so that the flash drive is primary and the bootloader will go to /dev/sdb.  However, I have always been able to switch the drive order and the bootloader then switches to default to /dev/sda.  But now it doesn't change.  I still only have the choice of /dev/sdb or /dev/sda1.  I will attach the requested log files, but they may not be complete as I didn't actually finish the install because of this issue.

I found these lines in the storage.log:
16:22:46,451 DEBUG storage: _gpt_disk_has_bios_boot(sda) returning True
16:22:46,451 DEBUG storage: is_valid_stage1_device(sda) returning True

I wonder if anaconda just isn't updating the settings any more when the drives are re-ordered.
Comment 3 Samuel Sieb 2011-10-30 20:12:03 EDT
Created attachment 530871 [details]
anaconda.log
Comment 4 Samuel Sieb 2011-10-30 20:12:25 EDT
Created attachment 530873 [details]
program.log
Comment 5 Adam Williamson 2011-11-01 00:19:32 EDT
Dupe of 744088, essentially. Writing live images with unetbootin isn't supported, note. I think, however, the fixed filtering code in final should also prevent anaconda from considering a unetbootin-written live stick as a bootloader target at all. so this should be fixed two ways.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 744088 ***
Comment 6 Samuel Sieb 2011-11-01 00:29:22 EDT
I may be misunderstanding your comment.  What I'm doing is taking the net install iso image and using livecd-iso-to-disk to put it on a USB flash drive.  I then tried to do an upgrade using that.  Is this method not supported or are you saying I should now have an option to pick the right drive?
Comment 7 Adam Williamson 2011-11-01 01:59:26 EDT
writing the images with unetbootin is not supported, as it's a third party tool we have no control over and frequently does the wrong thing. the recommended tool is livecd-iso-to-disk . but the issue ought to be fixed in final, if you test it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2011-11-01 02:04:12 EDT
what i'd expect to happen in final is for the usb stick to be filtered out, so it should give you the hard disk as the only available bootloader location.
Comment 9 Samuel Sieb 2011-11-02 02:03:50 EDT
I tested with RC4 and I get the exact same results as before.  It will only give me /dev/sdb.
Comment 10 Adam Williamson 2011-11-02 03:22:32 EDT
hum, that's a shame. can you please attach the logs from the installation?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2011-11-02 04:14:33 EDT
okay, so it looks like upgrades are still suffering from the 'usb install stick looks like a valid bootloader target' bug. :( closing as dupe of a similar report.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 750469 ***

Note You need to log in before you can comment on or make changes to this bug.