Bug 73752 - anacron freezes my computer
anacron freezes my computer
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anacron (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 23:29 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version: 2.3-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 02:55:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-09 23:29:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
It freezes my computer totally after a few seconds. I had to start from the
rescue cd and chmod -x /etc/init.d/anacron 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/anacron start
2.
3.
	

Actual Results:  The computer started to hang, and after a few seconds it was
totally unusable. It was impossible to gain control over my machine, even over
ssh. The only possible thing was to hit the reset button.

Additional info:

i run a strace and wrote the last sentences down.

SIGCHLD (Chile exited) ---
wait4(-1 [WIFEEXITED](s) && WEXITSTATUS(s) == 0, WHOHANG, NULL) = 4500
wait4(-1 0xbffff15c, WNOHANG,NULL) = -1 ECHILD (No child processes)
sigreturn () = ? (mask now [RTMIN])
rt_sigprocmask(SIG_BLOCK, [CHLD], [RTMIN], 8) = 0
rt_sigprocmask(SIG_SETMASK, [RTMIN], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [RTMIN], 8) = 0
rt_sigaction(SIGINT, {SIG_DFL}, {0x8075b70, [], 0x4000000}, 8 = 0
write(1, "\n", 1
)
rt_sigprocmask(SIG_SETMASK, [RTMIN], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [RTMIN], 8) = 0
read(255, "\nexit 0\", 934)
rt_sigprocmask(SIG_BLOCK, NULL, [RTMIN], 8) = 0
rt_sigprocmask(SIG_SETMASK, [RTMIN], NULL, 8) = 0
_exit (0) = ?

PS: I wrote all this by hand, to a sheet of paper, on back on the pc. I may have
made several typos.
Comment 1 Need Real Name 2002-09-09 23:33:02 EDT
anacron-2.3-22. I have exactly the same problems with cron. (pc hangs when cron
is starting, had to boot from rescue cd and chmod -x)
Comment 2 Jens Petersen 2002-09-10 02:22:53 EDT
Hrrm, can you give some more details about your install and hardware?
How much RAM, HD, swap space, CPU?

Output from top would probably be useful too.

What happens if you wait say 5-10min?  Does the machine become usable again?
Comment 3 Need Real Name 2002-09-10 14:19:42 EDT
Mem:   448852K av,  224620K used,  224232K free,       0K shrd,   27612K buff
Swap:  594396K av,       0K used,  594396K free                   93796K cached

df -h -T
Filesystem    Type    Size  Used Avail Use% Mounted on
/dev/hdh1     ext3    7.3G  6.3G  706M  91% /
none         tmpfs    219M     0  219M   0% /dev/shm
/dev/hde1     vfat    6.4G  6.5G     0 100% /mnt/windows
/dev/hde5     vfat     30G   25G  5.9G  81% /mnt/ibm
/dev/hdh5     ext3     66G   65G  863M  99% /mnt/kjempe
krs-dhcp232:/mnt/wd
               nfs     29G   23G  6.3G  78% /mnt/nfs

I have dual celeron333 on a Tekram motherboard. Afaik there is no hardware
problems with my computer, and it has been sucsessfully running RedHat linux
since 6.1 without problems.

Running top (even with -d 1s flag) is useless, because it starts hanging
immideately. 

I have waited for atleast 30min, without any improvement on my computers usability. 

Full Redhat null installation , upgraded from 7.2 -> 7.3 -> 8 beta. 2.4.18-11smp
kernel.
Comment 4 Jens Petersen 2003-07-09 22:51:55 EDT
In RHL 8.0 and later, the start of anacron is delayed for 60min after booting.

Do that make things any smoother for you?  Otherwise perhaps you're better off
disabling anacron all together.
Comment 5 Jens Petersen 2003-07-09 23:07:21 EDT
More importantly anacron is now run with "-s" (ie jobs are run serially),
so I suspect this is fixed in RHL 8.0 and 9.
Comment 6 Jens Petersen 2003-07-09 23:13:22 EDT

*** This bug has been marked as a duplicate of 65870 ***
Comment 7 Jens Petersen 2003-07-09 23:16:36 EDT
Oh, but this bug is against RHL 8.0.

Are you using anacron-2.3-23?
Comment 8 Jens Petersen 2004-01-15 02:55:50 EST
Closing for now.

Note You need to log in before you can comment on or make changes to this bug.