Bug 65870 - anacron behaves badly upon startup
anacron behaves badly upon startup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anacron (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 10:57 EDT by Garrett Mitchener
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 23:11:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2002-06-03 10:57:18 EDT
Description of Problem:


Hi, I've posted a parallel enhancement request under the apmd package.  Could
you please add the -s flag when running anacron in /etc/init.d/anacron?  This
means to run jobs sequentially instead of all at once.  My problem was that
without this flag, anacron runs my backup script and tripwire checks at the same
time and my computer slows to a crawl during all that hard drive activity.  With
-s, I don't have this problem, and I'm sure other people would appreciate this
small fix.
Comment 1 Bill Huang 2002-06-10 04:48:55 EDT
It is proper to add -s to serialize the jobs and it will satisfy your needs.
However for those who want to run their jobs without delay,how can I satisfy
them in the same time.
I understand your advice will make some users of anacron happy,but some of them
are unhappy after the changes are implemented.
So my opinion is customising the anacron by yourself is the best choice.
Comment 2 Jens Petersen 2002-08-23 07:27:22 EDT
Perhaps running the cron jobs serially might well make sense in some cases.
By definition cron jobs run by anacron are not run at the time
specified in the actual crontab file, so I don't see how they not
being run simulataneously should cause any problems.  I haven't

[The above mentioned apmd bug is bug 65869.]

However at least the system crontabs use run-parts to serialize the
execution of the jobs.  So can't you just do the same?
Comment 3 Garrett Mitchener 2002-08-26 22:07:39 EDT
The reason this is a problem on my system is that my backup script runs weekly,
but updatedb and tripwire run daily.  Once a week, anacron will use run-parts on
the daily and weekly jobs at the same time.
Comment 4 Jens Petersen 2002-08-28 05:47:15 EDT
(reopening)
Comment 5 Jens Petersen 2002-08-28 06:40:07 EDT
In anacron-2.3-23, /etc/init.d/anacron now starts anacron with the "-s"
option, and at nice level 19 incidently.
Comment 6 Jens Petersen 2003-07-09 23:13:24 EDT
*** Bug 73752 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.