Bug 737532 - FormatDestroyError: error wiping old signatures from /dev/sda-1: 1
Summary: FormatDestroyError: error wiping old signatures from /dev/sda-1: 1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8d33f5937af534d77bf5ee1d028...
: 738372 (view as bug list)
Depends On:
Blocks: F16Beta-accepted, F16BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-09-12 12:57 UTC by Robert Lightfoot
Modified: 2011-09-24 04:36 UTC (History)
7 users (show)

Fixed In Version: anaconda-16.19-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-24 04:36:29 UTC


Attachments (Terms of Use)
anaconda tb xml (323.64 KB, text/plain)
2011-09-15 22:00 UTC, Orion Poplawski
no flags Details
traceback from anaconda crash (522.14 KB, text/plain)
2011-09-16 16:16 UTC, Tim Flink
no flags Details

Description Robert Lightfoot 2011-09-12 12:57:36 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc3.git0.0.fc16.i686
product:        Fedora
reason:         FormatDestroyError: error wiping old signatures from /dev/sda-1: 1
time:           Mon Sep 12 08:57:02 2011
version:        16-Beta

description:
:The following was filed automatically by anaconda:
:anaconda 16.17 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 314, in destroy
:    raise FormatDestroyError(msg)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 1493, in _postCreate
:    DeviceFormat(device=self.path, exists=True).destroy()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 795, in create
:    self._postCreate()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 241, in execute
:    self.device.create(intf=intf)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 383, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:FormatDestroyError: error wiping old signatures from /dev/sda-1: 1

Comment 1 Chris Lumens 2011-09-12 20:54:52 UTC
Please attach /tmp/anaconda-tb-* to this bug report.  Thanks.

Comment 2 Robert Lightfoot 2011-09-15 00:22:38 UTC
THis was a test vm and I don't have the files any longer -- so I am closing this bug.

Comment 3 Orion Poplawski 2011-09-15 22:00:58 UTC
Created attachment 523456 [details]
anaconda tb xml

I just hit this today.  Here's the traceback.

Comment 4 Tim Flink 2011-09-16 16:16:33 UTC
Created attachment 523582 [details]
traceback from anaconda crash

I am able to reproduce this every time with the following in a VM. I was asked to add the tb an repro instructions here instead of #733449 (the bug that libreport identified).

Disk layout before installing:
20GB vdisk
  - 500M ext4 (primary partition 1)
  - 500M ext4 (primary partition 2)
  - 10G LVM pv (not encrypted - primary partition 3)
    + 1024 swap
    + rest is encrypted LV

1. boot Fedora 16 beta RC1 x86_64 netinstall with updates=http://dlehman.fedorapeople.org/updates-lvm.img
2. select new install (not upgrade)
3. select custom layout and use the following with existing layout from above
 - new encrypted pv (remainder of space, ~ 10G) (extended partition 5)
   + 1024 swap
   + remainder formatted as ext4 and mounted as /
 - use 500M ext4 partition as /boot (primary partition 2 from above)
4. When prompted for LUKS password, de-select "Add this passphrase to all existing encrypted devices to streamline the boot process"
5. After clicking on "write changes to disk", anaconda crashes

It may be worth noting that when I go back to redo the installation after the crash, the extended partition has been created but none of the other requested disk changes were done.

Comment 5 David Lehman 2011-09-16 16:17:15 UTC
To test my proposed fix, add the following to your boot command line:

  updates=http://dlehman.fedorapeople.org/updates-737532.img

Please let me know how it goes.

Comment 6 Tim Flink 2011-09-16 17:17:33 UTC
(In reply to comment #5)
> To test my proposed fix, add the following to your boot command line:
> 
>   updates=http://dlehman.fedorapeople.org/updates-737532.img
> 
> Please let me know how it goes.

I tried the same install procedure with this update and the installation completes without issue.

I completed a minimal install on the above layout and everything appears to be working.

Comment 7 Adam Williamson 2011-09-16 21:51:26 UTC
Proposing as NTH: this is a regression introduced by the fix for 733449, so if we're taking that fix as NTH for the next Beta spin, we should take this too. tflink, vote?

Comment 8 Tim Flink 2011-09-17 02:09:01 UTC
I'm +1 NTH on this, too. I don't think that there is a whole of extra risk since the fix was ready so quickly and we already need to focus on testing storage for anaconda anyways.

Comment 9 Andrew Schultz 2011-09-17 18:47:23 UTC
*** Bug 738372 has been marked as a duplicate of this bug. ***

Comment 10 Adam Williamson 2011-09-23 01:35:30 UTC
dlehman: is this one going to get committed for 16.19? be good not to lose it.

Comment 11 David Lehman 2011-09-23 14:05:13 UTC
Yes. It will be in anaconda-16.19.

Comment 12 Tim Flink 2011-09-23 18:35:08 UTC
Discussed in the 2011-09-23 blocker review meeting. Accepted as a Fedora 16 NTH because it came out of a fix for another NTH (#737916) and a fix is already available.

Comment 13 Fedora Update System 2011-09-23 21:48:58 UTC
anaconda-16.19-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.19-1.fc16

Comment 14 Fedora Update System 2011-09-24 04:35:34 UTC
anaconda-16.19-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.