Bug 7376 - Installation hangs on IPX
Installation hangs on IPX
Status: CLOSED DUPLICATE of bug 7494
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-27 11:10 EST by pergj
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 13:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pergj 1999-11-27 11:10:13 EST
The install (using tftp/nfs and the graphical installer), proceeded OK
until starting to install packages. The first four packages installed
without problems, but after the fifth (ldconfig) the installation hung. I
could switch to a virtual console, so the machine was not dead. I then
tried to use the text installer booting from a cdrom. The same result.

The only clue I have is that it might be that the kernel problem
described by Michael Faurot in the thread "Postgres &
Sparc2/IPX machines" on the redhat-sparc list could have something to
do with this. I do not know if the kernel patch he posted is included
in the kernel distributed with 6.1.
Comment 1 Doug Sand 1999-12-11 09:15:59 EST
Installation succeeded with no known problems on a SPARCstation LX using
floppy-boot/nfs, whereas floppy-boot/ftp fails.
Comment 2 bobrob 1999-12-14 17:46:59 EST
I see identical problems with IPX installation, and confirm the behavior
mentioned in bug #7243; that is, the very long pause between the installation
of each package.  Left the install running for 24 hours, only 72 packages were
installed (72 packages x approx 20 min/package = 24 hours, oddly enough).
Stopped and restarted install a number of times, same result.  Watched the
network traffic with a sniffer, when ftp session is actually begun session
proceeds very quickly; there is just a tremendous lag between initiation of
each successive ftp transfer.
Comment 3 jah 1999-12-17 09:49:59 EST
This is happening to me too. SPARC 2, boot net, FTP install.

It gets as far as installing ldconfig, then appears to hang. I left it running
overnight, it was still in the same point next morning. If it's going slowly,
it's going *very* slowly indeed!
Comment 4 stratcat 1999-12-28 21:15:59 EST
CD booted IPX hangs after ldconfig.
Left overnight as jah@alien.bt.co.uk above did.
Genuine Sun CDROM, 32MB RAM, no kbd or mouse, serial terminal as console
Machine installs and runs Solaris 7.
Comment 5 burked3 2000-01-15 06:49:59 EST
Happens to me on an IPX doing a CDROM install.  I've tried the Gnome & KDE
workstation install, both hung in the same spot.  The server install works
correctly.  Created images of both RPM and Non RPM CDROM, and it happens on
both.
Comment 6 Martin Cameron 2000-01-26 13:10:59 EST
I've an IPX 4/50 with 64M
Redhat6.1 installer freezes after ldconfig package,
when using gnome standard install. No kernel
warnings on the other ttys, either.
Minimum custom install works fine, though. Fixme.
Comment 7 garcia 2000-01-29 11:14:59 EST
I have exactly the same problem with my SS2, on my IPX (very light install) all
was OK (install by ftp from a PC linux box) but on the SS2 (64Mo of ram), the
installer hangs after during the installation of the ldconfig rpm.
Comment 8 graeme 2000-02-02 16:24:59 EST
Yet another 'Me Too'.  At first I suspected that my firewall was doing strange
stuff to passive FTP connections, but on other desktops, it works fine.

My workaround was to use an HTTP install instead.  It worked like a dream.

(It's an IPX, 32MB RAM, dodgy 200MB disk, 2 hops away from the install server.)
Comment 9 Jay Turner 2000-02-22 13:26:59 EST
*** This bug has been marked as a duplicate of 7494 ***

Note You need to log in before you can comment on or make changes to this bug.