Bug 7494 - FTP install dies on sun4c
FTP install dies on sun4c
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
: 7376 7833 8041 8921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-01 15:41 EST by Frank C. Brants
Modified: 2015-01-07 18:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 09:30:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank C. Brants 1999-12-01 15:41:38 EST
I successfully installed to my SS20 (sun4m) ftp'ing the files from my mail
server, moved the boot32.img floppy to my SS2 (sun4c) that was
(successfully) running RHL 6.0, rebooted from the floppy, started the
install ftp'ing the same set of files I had used for the SS20 & it hung
here, twice...

Fri Nov 26 09:53:47 1999 1 sparc.ashe84.com 122789
/pub/RedHat/RPMS/ldconfig-1.9
.5-16.sparc.rpm b _ o a anonymous@localhost.localdomain ftp 0 *

That's the last file it got before it died.  I repeated the attempt &
it died at the same spot.  So, I know the floppy image worked on my SS20 &
I know the file set was complete, the only thing that changed was the
architecture.

(From sparc-list@redhat.com)

Well after much interigation, the ftp install problem doesn't seem to be an
ftp problem.  After other install methods all failed and a little poking
around. It looks like something is wrong with ldconfig-1.9.5-16.sparc.rpm
Comment 1 jbsouthe 1999-12-01 16:19:59 EST
I posted the it
Comment 2 jbsouthe 1999-12-01 16:39:59 EST
The last post got eaten (i will repeat)
I got past that ldconfig file, just once out of six times, and just hung a little while later
on an IPX w/ redhat 6.1
Comment 3 Eric Bazerghi 1999-12-16 23:13:59 EST
A fellow user on the 'linux.redhat.sparc' newsgroup has found the answer to
this problem. It turns out to be a SCSI termination issue. Make sure that you
are not double-terminating your bus. In my case, one of the two drives in my
Sparc 2 was terminated. I disabled termination on both and the install now
works like a charm. Same solution for my IPX.
I'm curious as to what has changed since RH 6.0, since it installed with no
problems at all under the 'double-scsi-termination' situation...
Hats off to Hugo Curbelo for the solution!
Comment 4 Jay Turner 2000-02-15 09:58:59 EST
*** Bug 8921 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2000-02-22 13:26:59 EST
*** Bug 7376 has been marked as a duplicate of this bug. ***
Comment 6 Jay Turner 2000-02-22 14:05:59 EST
*** Bug 7833 has been marked as a duplicate of this bug. ***
Comment 7 graeme 2000-02-22 14:14:59 EST
I'm not sure that this is a satisfactory conclusion to this bug (in particular,
to 7376, which has been marked a duplicate).  My SCSI bus _is_ correctly
terminated (and the box has been running successfully, with no kernel messages
indicating aproblem with the SCSI bus) ever since.

The problem was apparent with an FTO install, but _not_ with an HTTP install.  I
was unable to test the NFS install, since NFS is blocked to that particular
subnet.
Comment 8 Jay Turner 2000-02-22 15:31:59 EST
*** Bug 8041 has been marked as a duplicate of this bug. ***
Comment 9 Martin Cameron 2000-06-06 09:41:29 EDT
I agree with Graeme.
I had a properly active terminated bus on my IPX, and the install would fail.
Only after removing ALL termination did the install begin to work. Also
I noticed that my yamaha 6416 cd-writer didn't disconnect ( causing the 
kernel to panic about the root filesystem ) when terminated, but I've moved it 
inside my PC now, so I can't test it without termination.
Perhaps the scsi driver is a bit dodgy, and requires bus retries to keep it
alive??

Note You need to log in before you can comment on or make changes to this bug.