Bug 737774 - can't install or upgrade to latest digikam or kipi-plugins
can't install or upgrade to latest digikam or kipi-plugins
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: digikam (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: 738735
  Show dependency treegraph
 
Reported: 2011-09-13 00:31 EDT by Rand All
Modified: 2011-09-23 00:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: digikam-2.0.0-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-23 00:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script file of several yum requests (14.09 KB, text/plain)
2011-09-13 00:32 EDT, Rand All
no flags Details

  None (edit)
Description Rand All 2011-09-13 00:31:15 EDT
I'm following the F16 x64 packages on a Core i7. Recently updates to kipi-plugins and opencv stopped working. I uninstalled kipi-plugins and digikam and was then able to upgrade opencv. I now can't install digikam or kipi-plugins.

Please see attachment for a demonstration of all the relevant yum commands.
Comment 1 Rand All 2011-09-13 00:32:55 EDT
Created attachment 522851 [details]
script file of several yum requests
Comment 2 nucleo 2011-09-13 05:59:24 EDT
Can you try to install opencv and kipi-plugins with disabled updates-testing repo?
Comment 3 nucleo 2011-09-13 07:55:43 EDT
opencv-2.3.1-1.fc16 pushed to stable
https://admin.fedoraproject.org/updates/FEDORA-2011-12320

Waiting for corrected release of digikam-2.1.1 that fixes database bug
https://bugs.kde.org/show_bug.cgi?id=281767
It will be built against opencv-2.3. when 2.1.1 will be released.

Or maybe submit digikam-2.0.0-4.fc16 to updates?
Comment 4 Fedora Update System 2011-09-13 20:40:07 EDT
digikam-2.0.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/digikam-2.0.0-4.fc16
Comment 5 Rand All 2011-09-14 02:35:49 EDT
(In reply to comment #2)
> Can you try to install opencv and kipi-plugins with disabled updates-testing
> repo?

Disabled updates-testing, tried to reinstall opencv and kipi, nothing changes. It still won't install.
Comment 6 nucleo 2011-09-14 04:47:24 EDT
Wait for digikam-2.0.0-4.fc16 appear in updates. It should fix bug.
Comment 7 Tim Flink 2011-09-16 16:57:43 EDT
Is there a release criterion that this violates? It sounds like a simple update to me.
Comment 8 nucleo 2011-09-16 17:26:37 EDT
I think maybe this criterion: 
"The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually."

Fedora 15 LiveCD contains digikam and kipi-plugins in default installation so update from this stable release using F16 Beta installer will be impossible because of broken deps in digikam.
Comment 9 Rex Dieter 2011-09-18 18:42:11 EDT
In short, f16 stable updates without *this* includes broken deps, stuff that's required for kde desktop/spin.

So at least a NTH, and it's been confirmed the update here fixes the issue, so pulling it in to f16-beta should be a no-brainer, imo.
Comment 10 Adam Williamson 2011-09-19 12:09:26 EDT
738735 is a blocker and depends on this, so we don't really need to mark this as a blocker in its own right. 738735 is the 'repoclosure on rc1 dvd' issue.
Comment 11 Adam Williamson 2011-09-21 20:54:53 EDT
Discussed at the 2011-09-21 go/no-go meeting (note: in #fedora-meeting-1), acting as a blocker review meeting. We agreed that this is obviously a blocker in effect, and we seem to need to add the AcceptedBlocker whiteboard field to stop it showing up on the 'proposed blocker' list, so we're doing that.
Comment 12 Fedora Update System 2011-09-23 00:03:33 EDT
digikam-2.0.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.